summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-07-13 22:58:33 +0100
committerChristopher Baines <mail@cbaines.net>2019-07-14 09:03:23 +0100
commita5c2e7961c21ef8620ce4cfb3569109fbd694e1e (patch)
tree675f868a58ef8e52248b5680a1c8669dfe11ec5d /gnu/packages/gstreamer.scm
parent2be878d8e54057980121e4c659ca48317b79970e (diff)
downloadguix-patches-a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.tar
guix-patches-a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.tar.gz
gnu: python-gst: Fix build failure.
Building python-gst fails with: Unbound variable: python-version Therefore, add python-build-system to #:modules so that it's imported, and give it a prefix to avoid clashing with the gnu-build-system. Also, simplify the code by using the site-packages function from the python-build-system module. * gnu/packages/gstreamer.scm (python-gst)[arguments]: Rework to fix build failure.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b0f0b032b3..18c567e8b0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -431,17 +431,14 @@ compression formats through the use of the libav library.")
"0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
(build-system gnu-build-system)
(arguments
- ;; XXX: Factorize python-sitedir with python-build-system.
- `(#:imported-modules (,@%gnu-build-system-modules
+ `(#:modules ((guix build gnu-build-system)
+ ((guix build python-build-system) #:prefix python:))
+ #:imported-modules (,@%gnu-build-system-modules
(guix build python-build-system))
#:configure-flags
- (let* ((python (assoc-ref %build-inputs "python"))
- (python-version (python-version python))
- (python-sitedir (string-append
- "lib/python" python-version "/site-packages")))
- (list (string-append
- "--with-pygi-overrides-dir=" %output "/" python-sitedir
- "/gi/overrides")))))
+ (list (string-append
+ "--with-pygi-overrides-dir="
+ (python:site-packages %build-inputs %outputs) "gi/overrides"))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python)))