summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/gstreamer.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 83d95673dd..9e7525bea5 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
@@ -690,10 +690,16 @@ model to base your own plug-in on, here it is.")
(patches (search-patches "gst-plugins-bad-fix-overflow.patch"))
(sha256
(base32
- "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))))
+ "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled copy of usrsctp.
+ (delete-file-recursively "ext/sctp/usrsctp")))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("-Dsctp-internal-usrsctp=disabled")
+ #:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
,@(if (string-prefix? "arm" (or (%current-target-system)
@@ -776,8 +782,8 @@ model to base your own plug-in on, here it is.")
;("qtdeclarative" ,qtdeclarative)
;("qtx11extras" ,qtx11extras)
("soundtouch" ,soundtouch)
- ;; GStreamer is not yet compatible with srt > 1.4.1.
- ("srt" ,srt-1.4.1)
+ ("srt" ,srt)
+ ("usrsctp" ,usrsctp)
("x265" ,x265)
("webrtc-audio-processing" ,webrtc-audio-processing)
("wayland" ,wayland)))