summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-21 18:11:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-21 18:18:15 +0200
commit9c2563a80b6f1d8fb8677f5314e6180ea9916aa5 (patch)
tree7180f199969379240cba3aec50b287d3c3175a61 /gnu/packages/gstreamer.scm
parent1dcca83afbc2a5b66f61f389971d257d2d65100d (diff)
downloadguix-patches-9c2563a80b6f1d8fb8677f5314e6180ea9916aa5.tar
guix-patches-9c2563a80b6f1d8fb8677f5314e6180ea9916aa5.tar.gz
build-system/python: Export 'python-version'.
* guix/build/python-build-system.scm (get-python-version): Rename to... (python-version): ... this. Update callers. Make public. * gnu/packages/gstreamer.scm (python-gst)[arguments]: Adjust accordingly. * gnu/packages/machine-learning.scm (ghmm)[arguments]: Likewise. * gnu/packages/openldap.scm (389-ds-base)[arguments]: Import (guix build python-build-system). Use 'python-version'. * gnu/packages/package-management.scm (conda)[arguments]: Use 'python-version'.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2a818e078c..39a4eb5fc0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -447,9 +447,7 @@ compression formats through the use of the libav library.")
(guix build python-build-system))
#:configure-flags
(let* ((python (assoc-ref %build-inputs "python"))
- (python-version ((@@ (guix build python-build-system)
- get-python-version)
- python))
+ (python-version (python-version python))
(python-sitedir (string-append
"lib/python" python-version "/site-packages")))
(list (string-append