summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-08 14:55:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:27 -0500
commit7ea92af5451702752d2f427275601324ffc2cd5b (patch)
tree6971a38d5d0518292d54fc904df1209ab8cb6f16 /gnu/packages/gstreamer.scm
parenta87cfa250db8af1037c00f0ede1f058b6adb223f (diff)
downloadguix-patches-7ea92af5451702752d2f427275601324ffc2cd5b.tar
guix-patches-7ea92af5451702752d2f427275601324ffc2cd5b.tar.gz
gnu: gst-plugins-good: Update to 1.18.5.
* gnu/packages/gstreamer.scm (gst-plugins-good): Update to 1.18.5. [source]: Remove the CVE patches, included in the release. * gnu/packages/patches/gst-plugins-good-CVE-2021-3497.patch: Delete file. * gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch: Likewise. * gnu/local.mk: De-register them.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 92042e0aae..ceeabbca4c 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -625,7 +625,7 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.18.4")
+ (version "1.18.5")
(source
(origin
(method url-fetch)
@@ -633,11 +633,9 @@ for the GStreamer multimedia library.")
(string-append
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
- (patches (search-patches "gst-plugins-good-fix-test.patch"
- "gst-plugins-good-CVE-2021-3497.patch"
- "gst-plugins-good-CVE-2021-3498.patch"))
+ (patches (search-patches "gst-plugins-good-fix-test.patch"))
(sha256
- (base32 "1c1rpq709cy8maaykyn1n0kckj9c6fl3mhvixkk6xmdwkcx0xrdn"))))
+ (base32 "0svrapawych2s3lm4lx3x023zxq5kcx50jnfmh0qigszfskyxbis"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas