summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-06 00:13:23 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:09:55 +0200
commit7508378d1f69e21822221ffe39b38a25241ea7b1 (patch)
tree95b71a921f8d0eacdccd19d56529e84428eacc8f /gnu/packages/gstreamer.scm
parent433bb35336a2e583d1f8559407e0fc68b597fae8 (diff)
downloadguix-patches-7508378d1f69e21822221ffe39b38a25241ea7b1.tar
guix-patches-7508378d1f69e21822221ffe39b38a25241ea7b1.tar.gz
gnu: Add openni2.
* gnu/packages/gstreamer.scm (openni2): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index eb2ad2389f..0b0ca21113 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -53,8 +53,12 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphics)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages iso-codes)
+ #:use-module (gnu packages java)
+ #:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
@@ -79,6 +83,44 @@
#:use-module (gnu packages assembly)
#:use-module (gnu packages xml))
+(define-public openni2
+ (package
+ (name "openni2")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/occipital/OpenNI2.git")
+ (commit (string-append "v" version "-debian"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mfnyzpq53wnzgjfx91xcbx0nrl0lp1vrk1rk20a3gb3kshsr675"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("graphviz" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("openjdk" ,openjdk14)
+ ("openjdk:jdk" ,openjdk14 "jdk")
+ ("python" ,python-wrapper)))
+ (inputs
+ `(("freeglut3" ,freeglut)
+ ("libudev" ,eudev)
+ ("libusb" ,libusb)))
+ (synopsis "Framework for sensor-based 'Natural Interaction")
+ (description "OpenNI is a framework for getting data to support
+'Natural Interaction', i.e. skeleton tracking, gesture tracking, and similar
+ways of getting data from humans. It provides the interface for physical devices
+and for middleware components.")
+ (home-page "https://structure.io/openni")
+ (license license:asl2.0)))
+
(define-public libdc1394
(package
(name "libdc1394")