summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-13 11:35:44 +0100
committerMarius Bakke <marius@gnu.org>2020-11-13 13:00:02 +0100
commit69967919b3d16afe9ac3f13f94867eac373c858c (patch)
tree7e000f2ffedcfff0964cd649ac1cc61a6a3a9738 /gnu/packages/gstreamer.scm
parent4688dc9bb89a3b753edcbcfb6bcd5ef0df69e584 (diff)
downloadguix-patches-69967919b3d16afe9ac3f13f94867eac373c858c.tar
guix-patches-69967919b3d16afe9ac3f13f94867eac373c858c.tar.gz
gnu: gst-plugins-good: Fix test failure on 32-bit systems.
* gnu/packages/gstreamer.scm (gst-plugins-good)[arguments]: Add phase fix-broken-test.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 4c3e3419ef..b74b6fdc00 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -597,6 +597,14 @@ for the GStreamer multimedia library.")
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-broken-test
+ (lambda _
+ ;; Fix test failure on 32-bit. Remove for > 1.18.1.
+ ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/803
+ (substitute* "tests/check/elements/qtdemux.c"
+ (("10000000")
+ "G_GUINT64_CONSTANT (10000000)"))
+ #t))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.