summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-29 19:07:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-29 23:17:13 +0200
commit55d1d9eb2f0051404d0562622d5d85b701f5a973 (patch)
treeaaf197256b737872e8c08bb15431f0436ad6578f /gnu/packages/gstreamer.scm
parentbdb51ed6d16c8fb3f934991f991ca44fdbac715e (diff)
downloadguix-patches-55d1d9eb2f0051404d0562622d5d85b701f5a973.tar
guix-patches-55d1d9eb2f0051404d0562622d5d85b701f5a973.tar.gz
gnu: gstreamer: Fix buffer offset problem.
* gnu/packages/patches/gstreamer-buffer-reset-offset.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gstreamer.scm (gstreamer)[source](patches): New field. [arguments]: Do not disable any tests.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2a818e078c..13c2c2fc27 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -110,6 +110,7 @@ arrays of data.")
(uri (string-append
"https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
version ".tar.xz"))
+ (patches (search-patches "gstreamer-buffer-reset-offset.patch"))
(sha256
(base32
"003wy1p1in85p9sr5jsyhbnwqaiwz069flwkhyx7qhxy31qjz3hf"))))
@@ -119,19 +120,7 @@ arrays of data.")
`(#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
-
- ,@(if (not (target-64bit?))
- ;; Skip test that fails on 32-bit systems:
- ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/316>.
- `(#:phases (modify-phases %standard-phases
- (add-before 'check 'disable-gstbufferpool-test
- (lambda _
- (substitute* "tests/check/Makefile"
- (("^[[:blank:]]+gst/gstbufferpool.*$")
- ""))
- #t))))
- '())))
+ "/share/gtk-doc/html"))))
(propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
(native-inputs
`(("bison" ,bison)