summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-04 12:39:31 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-04 12:42:29 +0800
commit4ec48644c3b3760bcc8a72eb6956c678b57182a1 (patch)
tree48ffa2a11bcbb177b5ec9c180ae225612f7fdcdb /gnu/packages/gstreamer.scm
parente9a8212959bd3df13ee18f018299e43bccfafc68 (diff)
downloadguix-patches-4ec48644c3b3760bcc8a72eb6956c678b57182a1.tar
guix-patches-4ec48644c3b3760bcc8a72eb6956c678b57182a1.tar.gz
gnu: gst-plugins-base: Enable GObjection introspection.
* gnu/packages/gstreamer.scm (gst-plugins-base): Add gobject-introspection to 'native-inputs'. [arguments]<#:phases>: Rename patch-test-pb-utils to patch. Add (setenv "CC" "gcc") to patch phase.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index e941f8b2a0..ad0cfccca9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -176,6 +176,7 @@ This package provides the core library and elements.")
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)))
(arguments
`(#:configure-flags
@@ -184,10 +185,12 @@ This package provides the core library and elements.")
"/share/gtk-doc/html"))
#:phases
(alist-cons-before
- 'configure 'patch-test-pb-utils
+ 'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
- (("/bin/sh") (which "sh"))))
+ (("/bin/sh") (which "sh")))
+ ;; for g-ir-scanner.
+ (setenv "CC" "gcc"))
%standard-phases)))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis