summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-12 11:36:08 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:18 -0500
commit4c0a39ee65b4f7d57e5f5156b2291dafbb69587f (patch)
tree852c69938d5a0599f33f54f65982a212fbb9187b /gnu/packages/gstreamer.scm
parenta67cb232d7fb2461876a35bc6c3eeded29858b97 (diff)
downloadguix-patches-4c0a39ee65b4f7d57e5f5156b2291dafbb69587f.tar
guix-patches-4c0a39ee65b4f7d57e5f5156b2291dafbb69587f.tar.gz
gnu: gst-plugins-base: Enable more features.
* gnu/packages/gstreamer.scm (gst-plugins-base) [inputs]: Add graphene, iso-codes, libgudev, libjpeg-turbo, libpng, libvisual, mesa, wayland-protocols, wayland. [native-inputs]: Add gettext-minimal and xorg-server-for-test. [arguments]: Remove '-Dgl=disabled' from configure flags. Add pre-check phase. Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at> Co-authored-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm37
1 files changed, 30 insertions, 7 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2f6097414c..a9f21367df 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -559,6 +559,7 @@ This package provides the core library and elements.")
'()
`(("orc" ,orc))))) ;required by gstreamer-audio-1.0.pc
(inputs
+ ;; TODO: Add libvorbisidec
`(("cdparanoia" ,cdparanoia)
("pango" ,pango)
("libogg" ,libogg)
@@ -569,21 +570,43 @@ This package provides the core library and elements.")
("libXext" ,libxext)
("libxv" ,libxv)
("alsa-lib" ,alsa-lib)
- ("opus" ,opus)))
+ ("opus" ,opus)
+ ("graphene" ,graphene)
+ ("iso-codes" ,iso-codes)
+ ("libgudev" ,libgudev)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libvisual" ,libvisual)
+ ("mesa" ,mesa)
+ ("wayland-protocols" ,wayland-protocols)
+ ("wayland" ,wayland)))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("python-wrapper" ,python-wrapper)))
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("python-wrapper" ,python-wrapper)
+ ("gettext" ,gettext-minimal)
+ ("xorg-server" ,xorg-server-for-tests)))
(arguments
- `(#:configure-flags '("-Dgl=disabled")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
(add-before 'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
(("/bin/sh") (which "sh")))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 +extension GLX &")
+ (setenv "DISPLAY" ":1")
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ ;; Tests look for $XDG_RUNTIME_DIR.
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
+ ;; For missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
#t)))))
(home-page "https://gstreamer.freedesktop.org/")
(synopsis