summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-09 12:57:19 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-09 12:57:19 +0200
commit45b01f2e05ce05ef796c186260e86c9042731cc0 (patch)
tree01bf4ae49d5064e1776a13c0320c305d62509801 /gnu/packages/gstreamer.scm
parent4442d4dc409a9361d22760f184b294ef0421c8da (diff)
downloadguix-patches-45b01f2e05ce05ef796c186260e86c9042731cc0.tar
guix-patches-45b01f2e05ce05ef796c186260e86c9042731cc0.tar.gz
gnu: orc: Update to 0.4.30.
* gnu/packages/gstreamer.scm (orc): Update to 0.4.30. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Adjust phase order to cope with the new out-of-source build. [native-inputs]: Add GTK-DOC.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1ec161a599..065f92deb6 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -29,6 +29,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages audio)
@@ -68,19 +69,19 @@
(define-public orc
(package
(name "orc")
- (version "0.4.29")
+ (version "0.4.30")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
(sha256
(base32
- "1cisbbn69p9c8vikn0nin14q0zscby5m8cyvzxyw2pjb2kwh32ag"))))
- (build-system gnu-build-system)
+ "0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
+ (build-system meson-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'check 'disable-faulty-test
+ (add-after 'unpack 'disable-faulty-test
(lambda _
;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
;; tests, which fail on some machines. See:
@@ -90,6 +91,8 @@
(("if \\(error\\) return 1;")
"if (error) return 77;"))
#t)))))
+ (native-inputs
+ `(("gtk-doc" ,gtk-doc)))
(home-page "https://gstreamer.freedesktop.org/modules/orc.html")
(synopsis "Oil runtime compiler")
(description