summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-04 23:50:51 +0200
committerMarius Bakke <marius@gnu.org>2021-10-05 19:52:30 +0200
commit3cf6f92f09234c1cfff34870c4a7307297cda01a (patch)
tree0a94b0fbd1ae6df1d69c389e2213ad12c991fc53 /gnu/packages/gstreamer.scm
parentfa72aa8f4d6f276609546f93cea34cccd98f51f4 (diff)
downloadguix-patches-3cf6f92f09234c1cfff34870c4a7307297cda01a.tar
guix-patches-3cf6f92f09234c1cfff34870c4a7307297cda01a.tar.gz
gnu: gst-plugins-bad: Build with system usrsctp.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[source](modules, snippet): New fields. [arguments]: Add #:configure-flags. [inputs]: Add USRSCTP.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index c734d0c74e..3f5edbe4aa 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -685,10 +685,16 @@ model to base your own plug-in on, here it is.")
(patches (search-patches "gst-plugins-bad-fix-overflow.patch"))
(sha256
(base32
- "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))))
+ "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled copy of usrsctp.
+ (delete-file-recursively "ext/sctp/usrsctp")))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("-Dsctp-internal-usrsctp=disabled")
+ #:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
,@(if (string-prefix? "arm" (or (%current-target-system)
@@ -773,6 +779,7 @@ model to base your own plug-in on, here it is.")
("soundtouch" ,soundtouch)
;; GStreamer is not yet compatible with srt > 1.4.1.
("srt" ,srt-1.4.1)
+ ("usrsctp" ,usrsctp)
("x265" ,x265)
("webrtc-audio-processing" ,webrtc-audio-processing)
("wayland" ,wayland)))