summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-20 21:41:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 23:18:48 +0100
commit2dc277dd997da8ada68349ea321192719edc814c (patch)
treed5d759884abb0d413b234927ecc90cd57bb2b3d8 /gnu/packages/gstreamer.scm
parent321f47c25d82fa510ea4e1891f719c4255272e39 (diff)
downloadguix-patches-2dc277dd997da8ada68349ea321192719edc814c.tar
guix-patches-2dc277dd997da8ada68349ea321192719edc814c.tar.gz
gnu: gst-plugins-bad: Build with Meson.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[outputs]: Remove. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Enable tests, except for one. Disable documentation generation.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 310f5388bc..7bbb564d16 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -297,19 +297,24 @@ developers consider to have good quality code and correct functionality.")
(sha256
(base32
"0x0y0hm0ga3zqi5q4090hw5sjh59y1ry9ak16qsaascm72i7mjzi"))))
- (outputs '("out" "doc"))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- '(#:tests? #f ; XXX: 13 of 53 tests fail
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ ;; FIXME: Why is this failing.
+ (substitute* "tests/check/meson.build"
+ ((".*elements/dash_mpd\\.c.*")
+ ""))
+ #t)))))
(propagated-inputs
`(("gst-plugins-base" ,gst-plugins-base)))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
+ ;; TODO: Enable documentation for 1.18.
+ ;;("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)
("python" ,python)))
(inputs