summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-13 14:08:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-13 14:08:32 +0200
commit2a9d89afb6fb869dd2bdf1e9f710f487786930fc (patch)
tree65e09643b43469b5d094f34ccf16624f0b3b01d2 /gnu/packages/gstreamer.scm
parent2916deb91bd7ea3e76ff9693a283c244e3ffd0be (diff)
downloadguix-patches-2a9d89afb6fb869dd2bdf1e9f710f487786930fc.tar
guix-patches-2a9d89afb6fb869dd2bdf1e9f710f487786930fc.tar.gz
gnu: gstreamer: Skip failing test on 32-bit systems.
* gnu/packages/gstreamer.scm (gstreamer)[arguments]: When building for a 32-bit system, add #:phases.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index d5d14152fb..2a818e078c 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -118,7 +119,19 @@ arrays of data.")
`(#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ "/share/gtk-doc/html"))
+
+ ,@(if (not (target-64bit?))
+ ;; Skip test that fails on 32-bit systems:
+ ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/316>.
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-gstbufferpool-test
+ (lambda _
+ (substitute* "tests/check/Makefile"
+ (("^[[:blank:]]+gst/gstbufferpool.*$")
+ ""))
+ #t))))
+ '())))
(propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
(native-inputs
`(("bison" ,bison)