summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-02-05 16:09:53 +0800
committer宋文武 <iyzsong@gmail.com>2015-02-05 16:11:23 +0800
commit195857b0f75332898b7531b85d2c36bd8c0f325b (patch)
tree339fde8e952c7e7587d657e646f81e138299c96e /gnu/packages/gstreamer.scm
parent666aa995f0486a0753a8bb68a5e32c675d0f8b5b (diff)
downloadguix-patches-195857b0f75332898b7531b85d2c36bd8c0f325b.tar
guix-patches-195857b0f75332898b7531b85d2c36bd8c0f325b.tar.gz
gnu: Add orc.
* gnu/packages/gstreamer.scm (orc): New variable.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 003b78a0cf..2332ef630d 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,7 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gstreamer)
- #:use-module ((guix licenses) #:select (lgpl2.0+))
+ #:use-module ((guix licenses) #:select (lgpl2.0+ bsd-2 bsd-3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -38,6 +39,28 @@
#:use-module (gnu packages python)
#:use-module (gnu packages xml))
+(define-public orc
+ (package
+ (name "orc")
+ (version "0.4.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/data/src/"
+ "orc/orc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1ryz1gfgrxcj806cakcblxf0bcwq8p2mw8k86fs3f5wlwayawzkn"))))
+ (build-system gnu-build-system)
+ (home-page "http://code.entropywave.com/orc/")
+ (synopsis "Oil runtime compiler")
+ (description
+ "Orc is a just-in-time compiler implemented as a library and set of
+associated tools for compiling and executing simple programs that operate on
+arrays of data.")
+ ;; The source code implementing the Marsenne Twister algorithm is licensed
+ ;; under the 3-clause BSD license, the rest is under 2-clause BSD license.
+ (license (list bsd-2 bsd-3))))
+
(define-public gstreamer
(package
(name "gstreamer")