summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-18 00:24:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-18 01:08:29 +0300
commit17984b079495b79e1dba57113b3b9e44a632cc3c (patch)
tree5c63c4154494b0b190f564d423e2618d12c15d62 /gnu/packages/gstreamer.scm
parent84997d95065b47591b058b573f4c42dd4df5c51f (diff)
downloadguix-patches-17984b079495b79e1dba57113b3b9e44a632cc3c.tar
guix-patches-17984b079495b79e1dba57113b3b9e44a632cc3c.tar.gz
gnu: gst-plugins-bad: Limit inputs based on architecture.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[inputs]: Only build with mediasdk and svt-hevc on supported architectures.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index dd537c9d10..a1503602ad 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -841,7 +841,9 @@ model to base your own plug-in on, here it is.")
("libgme" ,libgme)
("libgudev" ,libgudev)
("libkate" ,libkate)
- ("libmfx" ,mediasdk)
+ ,@(if (target-x86?)
+ `(("libmfx" ,mediasdk))
+ '())
("libmms" ,libmms)
("libmodplug" ,libmodplug)
("libmpcdec" ,libmpcdec)
@@ -887,7 +889,9 @@ model to base your own plug-in on, here it is.")
("soundtouch" ,soundtouch)
("spandsp" ,spandsp)
("srt" ,srt)
- ("svthevcenc" ,svt-hevc)
+ ,@(if (target-x86?)
+ `(("svthevcenc" ,svt-hevc))
+ '())
("tinyalsa" ,tinyalsa)
("transcode" ,transcode)
("usrsctp" ,usrsctp)