summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-16 12:54:17 -0400
committerLeo Famulari <leo@famulari.name>2018-10-16 13:40:14 -0400
commit02d5ed4a2700e8613aaf0642333734b60caff0f7 (patch)
tree22c538bc4f5909f1d9ea4d128da7bd1284f7455b /gnu/packages/gstreamer.scm
parent2d4a753a7cd38a3e7b95066bc92f1c0196737b70 (diff)
downloadguix-patches-02d5ed4a2700e8613aaf0642333734b60caff0f7.tar
guix-patches-02d5ed4a2700e8613aaf0642333734b60caff0f7.tar.gz
gnu: GStreamer plugins: Update MP3 features for GStreamer 1.14.
GStreamer moved all MPEG-1 audio (mp1, mp2, and mp3) decoders and encoders to the group of "good" plugins in GStreamer 1.14.0. See the 'NEWS' file for more information. * gnu/packages/gstreamer.scm (gst-plugins-ugly)[inputs]: Remove lame, mpg123, and twolame. (gst-plugins-bad): Remove mpg123. (gst-plugins-good): Add lame, mpg123, and twolame.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index f556861857..435c3e5b3a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -227,6 +227,7 @@ for the GStreamer multimedia library.")
("gdk-pixbuf" ,gdk-pixbuf)
("gst-plugins-base" ,gst-plugins-base)
("jack" ,jack-1)
+ ("lame" ,lame)
("libavc1394" ,libavc1394)
("libcaca" ,libcaca)
("libdv" ,libdv)
@@ -236,10 +237,12 @@ for the GStreamer multimedia library.")
("libshout" ,libshout)
("libsoup" ,libsoup)
("libvpx" ,libvpx)
+ ("mpg123" ,mpg123)
("orc" ,orc)
("pulseaudio" ,pulseaudio)
("speex" ,speex)
("taglib" ,taglib)
+ ("twolame" ,twolame)
("wavpack" ,wavpack)))
(native-inputs
`(("glib:bin" ,glib "bin")
@@ -320,7 +323,6 @@ developers consider to have good quality code and correct functionality.")
("libxml2" ,libxml2)
("lrdf" ,lrdf)
("mesa" ,mesa)
- ("mpg123" ,mpg123)
("neon" ,neon)
("openal" ,openal)
("openexr" ,openexr)
@@ -357,13 +359,10 @@ par compared to the rest.")
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
("liba52" ,liba52)
- ("lame" ,lame)
("libcdio" ,libcdio)
- ("twolame" ,twolame)
("libmpeg2" ,libmpeg2)
("libdvdread" ,libdvdread)
("libx264" ,libx264)
- ("mpg123" ,mpg123)
;; TODO:
;; * opencore-amr (for the AMR-NB decoder and encoder and the
;; AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>