summaryrefslogtreecommitdiff
path: root/gnu/packages/gsasl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/gsasl.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
guix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/gsasl.scm')
-rw-r--r--gnu/packages/gsasl.scm113
1 files changed, 113 insertions, 0 deletions
diff --git a/gnu/packages/gsasl.scm b/gnu/packages/gsasl.scm
new file mode 100644
index 0000000000..dc75b18455
--- /dev/null
+++ b/gnu/packages/gsasl.scm
@@ -0,0 +1,113 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gsasl)
+ #:use-module (distro)
+ #:use-module ((gnu packages compression)
+ #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages gnutls)
+ #:use-module (gnu packages libidn)
+ #:use-module (gnu packages nettle)
+ #:use-module (gnu packages shishi)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libntlm
+ (package
+ (name "libntlm")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.nongnu.org/libntlm/releases/libntlm-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "101pr110ardcj2di940g6vaqifsaxc44h6hjn81l63dvmkj5a6ga"))))
+ (build-system gnu-build-system)
+ (synopsis "Libntlm, a library that implements NTLM authentication")
+ (description
+ "Libntlm is a library that implements NTLM authentication")
+ (license lgpl2.1+)
+ (home-page "http://www.nongnu.org/libntlm/")))
+
+(define-public gss
+ (package
+ (name "gss")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gss/gss-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "1qa8lbkzi6ilfggx7mchfzjnchvhwi68rck3jf9j4425ncz7zsd9"))))
+ (build-system gnu-build-system)
+ (inputs `(("nettle" ,nettle)
+ ("shishi" ,shishi)
+ ("zlib" ,guix:zlib)
+ ))
+ (synopsis "GNU GSS (Generic Security Service), a free implementatio of RFC 2743/2744")
+ (description
+ "GNU GSS is an implementation of the Generic Security Service Application
+Program Interface (GSS-API). GSS-API is used by network servers to provide
+security services, e.g., to authenticate SMTP/IMAP clients against
+SMTP/IMAP servers. GSS consists of a library and a manual.")
+ (license gpl3+)
+ (home-page "http://www.gnu.org/software/gss/")))
+
+(define-public gsasl
+ (package
+ (name "gsasl")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gsasl/gsasl-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "1rci64cxvcfr8xcjpqc4inpfq7aw4snnsbf5xz7d30nhvv8n40ii"))))
+ (build-system gnu-build-system)
+ (inputs `(("libidn" ,libidn)
+ ("libntlm" ,libntlm)
+ ("gnutls" ,gnutls)
+ ("gss" ,gss)
+ ("zlib" ,guix:zlib)
+ ))
+ (synopsis "GNU SASL, an implementation of the Simple Authentication and Security Layer framework")
+ (description
+ "GNU SASL is an implementation of the Simple Authentication and Security
+Layer framework and a few common SASL mechanisms. SASL is used by network
+servers (e.g., IMAP, SMTP) to request authentication from clients, and in
+clients to authenticate against servers.
+
+GNU SASL consists of a library (libgsasl), a command line utility (gsasl)
+to access the library from the shell, and a manual. The library includes
+support for the framework (with authentication functions and application
+data privacy and integrity functions) and at least partial support for the
+CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID, DIGEST-MD5,
+SCRAM-SHA-1, SCRAM-SHA-1-PLUS, LOGIN, and NTLM mechanisms.
+
+The library is portable because it does not do network communication by
+itself, but rather leaves it up to the calling application. The library is
+flexible with regards to the authorization infrastructure used, as it
+utilises callbacks into the application to decide whether an user is
+authorised or not.
+
+The gsasl package distribution includes the library part as well,
+so there is no need to install two packages.")
+ (license gpl3+)
+ (home-page "http://www.gnu.org/software/gsasl/")))