summaryrefslogtreecommitdiff
path: root/gnu/packages/groovy.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-16 14:34:23 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:36:58 +0200
commitdabce25015f74921b4144fcd5b032f89129f0988 (patch)
treef16fb3d8ab33aa348c21e07535bcc9321dfba2c0 /gnu/packages/groovy.scm
parenta6494dcf8a128de6fad7a2429534bc373be60eab (diff)
downloadguix-patches-dabce25015f74921b4144fcd5b032f89129f0988.tar
guix-patches-dabce25015f74921b4144fcd5b032f89129f0988.tar.gz
gnu: Add groovy-groovysh.
* gnu/packages/groovy.scm (groovy-groovysh): New variable.
Diffstat (limited to 'gnu/packages/groovy.scm')
-rw-r--r--gnu/packages/groovy.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index 54852c05bb..2fc25d955e 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -646,3 +646,57 @@ library used to build graphical interfaces.")))
(synopsis "Groovy documentation generation")
(description "This package contains a command line tool to generate
documentation for groovy applications.")))
+
+(define groovy-groovysh
+ (package
+ (inherit groovy-bootstrap)
+ (name "groovy-groovysh")
+ (arguments
+ `(#:jar-name "groovy-groovysh.jar"
+ #:test-dir "src/test"
+ #:jdk ,icedtea-8
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "subprojects/groovy-groovysh")
+ #t))
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "src/main/resources" "build/classes")
+ #t))
+ (replace 'build
+ (lambda _
+ (mkdir-p "build/classes")
+ (mkdir-p "build/jar")
+ (apply invoke "java" "-cp" (getenv "CLASSPATH")
+ "org.codehaus.groovy.tools.FileSystemCompiler"
+ "-d" "build/classes" "-j"; joint compilation
+ (find-files "src/main" ".*\\.(groovy|java)$"))
+ (invoke "jar" "-cf" "build/jar/groovy-groovysh.jar"
+ "-C" "build/classes" ".")
+ #t))
+ (replace 'check
+ (lambda _
+ (mkdir-p "build/test-classes")
+ (substitute* "build.xml"
+ (("depends=\"compile-tests\"") "depends=\"\"")
+ (("}/java") "}/groovy"))
+ (apply invoke "java" "-cp"
+ (string-append (getenv "CLASSPATH") ":build/classes")
+ "org.codehaus.groovy.tools.FileSystemCompiler"
+ "-d" "build/test-classes" "-j"
+ (append (find-files "src/test" ".*\\.(groovy|java)$")))
+ (invoke "ant" "check")
+ #t)))))
+ (inputs
+ `(("groovy-xml" ,groovy-xml)
+ ("groovy-console" ,groovy-console)
+ ,@(package-inputs groovy-bootstrap)))
+ (native-inputs
+ `(("groovy-bootstrap" ,groovy-bootstrap)
+ ("groovy-test" ,groovy-test)
+ ("groovy-tests-bootstrap" ,groovy-tests-bootstrap)
+ ,@(package-native-inputs java-groovy-bootstrap)))
+ (synopsis "Groovy REPL")
+ (description "This package contains the Groovy REPL.")))