summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-16 15:00:04 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-16 15:15:30 +0100
commitf57693e17c7905d2f11e46d04cb558fe0b0fc39b (patch)
tree40bcbb26a1ab7561a9efd8d7245ed7637bbbc123 /gnu/packages/groff.scm
parentbe1ce9fd316cf1ffa72e842d180a673d6658748f (diff)
downloadguix-patches-f57693e17c7905d2f11e46d04cb558fe0b0fc39b.tar
guix-patches-f57693e17c7905d2f11e46d04cb558fe0b0fc39b.tar.gz
gnu: groff: Disable relocatability.
* gnu/packages/groff.scm (groff)[arguments]<#:phases>[disable-relocatability]: New phase.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 77728a5d78..62e844e1ed 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -62,6 +62,34 @@
`(#:parallel-build? #f ; parallel build fails
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-relocatability
+ (lambda _
+ ;; Groff contains a Rube Goldberg-esque relocator for the file
+ ;; "charset.alias". It tries to find the current executable
+ ;; using realpath, a do-it-yourself search in $PATH and so on.
+ ;; Furthermore, the routine that does the search is buggy
+ ;; in that it doesn't handle error cases when they arise.
+ ;; This causes preconv to segfault when trying to look up
+ ;; the file "charset.alias" in the NULL location.
+ ;; The "charset.alias" parser is a copy of gnulib's, and a
+ ;; non-broken version of gnulib's "charset.alias" parser is
+ ;; part of glibc's libcharset.
+ ;; However, groff unconditionally uses their own
+ ;; "charset.alias" parser, but then DOES NOT INSTALL the
+ ;; file "charset.alias" when glibc is too new.
+ ;; In Guix, our file "charset.alias" only contains an obscure
+ ;; alias for ASCII and nothing else. So just disable relocation
+ ;; and make the entire "charset.alias" lookup fail.
+ ;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=30785> for
+ ;; details.
+ (substitute* "src/libs/libgroff/Makefile.sub"
+ (("-DENABLE_RELOCATABLE=1") ""))
+ ;; That file contains a crash bug--so make sure that
+ ;; its contents are not there.
+ (call-with-output-file "src/libs/libgroff/relocate.cpp"
+ (lambda (port)
+ #t))
+ #t))
(add-after 'unpack 'setenv
(lambda _
(setenv "GS_GENERATE_UUIDS" "0")