summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-15 09:37:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-15 09:37:18 +0300
commit8aea855ac1fe05fc462206adb607d639a06b50a5 (patch)
tree341fdb8c197bb4f0200c41be7e6b1621aea0d0ac /gnu/packages/groff.scm
parent818237d947f0f48eaa1033bca9e090ceeeb5a9ab (diff)
downloadguix-patches-8aea855ac1fe05fc462206adb607d639a06b50a5.tar
guix-patches-8aea855ac1fe05fc462206adb607d639a06b50a5.tar.gz
gnu: roffit: Wrap binary.
Fixes <https://debbugs.gnu.org/43306>. * gnu/packages/groff.scm (roffit)[arguments]: Add 'wrap-binary phase to help find perl libraries.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 3a44497594..0daf614302 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -201,7 +201,13 @@ is usually the formatter of \"man\" documentation pages.")
(lambda* (#:key outputs #:allow-other-keys)
(mkdir-p (string-append (assoc-ref outputs "out")
"/bin"))
- #t)))))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/roffit")
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))
+ #t))))))
(native-inputs `(("html-tree" ,perl-html-tree))) ; for test
(inputs
`(("perl" ,perl)))