summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/groff.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index fdb8440a39..1d2af7ff07 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -60,7 +60,7 @@
;; own HTML doc, nor does it change its capabilities, so we removed netpbm
;; from 'inputs'.
- (inputs `(("ghostscript" ,ghostscript)))
+ (inputs (list ghostscript))
;; When cross-compiling, this package depends upon a native install of
;; itself.
@@ -207,7 +207,7 @@ is usually the formatter of \"man\" documentation pages.")
#t))))))
(native-inputs `(("html-tree" ,perl-html-tree))) ; for test
(inputs
- `(("perl" ,perl)))
+ (list perl))
(home-page "https://daniel.haxx.se/projects/roffit/")
(synopsis "Convert nroff files to HTML")
(description
@@ -250,9 +250,7 @@ It is typically used to display man pages on a web site.")
"ruby-nokogiri")))))
#t)))))
(inputs
- `(("ruby-kramdown" ,ruby-kramdown)
- ("ruby-mustache" ,ruby-mustache)
- ("ruby-nokogiri" ,ruby-nokogiri)))
+ (list ruby-kramdown ruby-mustache ruby-nokogiri))
(synopsis
"Build manuals in HTML and Unix man page format from Markdown")
(description