summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-16 15:00:04 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-17 10:07:07 +0100
commit73b2ce87956b0d9168dcfa234128b91e0e41a4c7 (patch)
tree24d5130975d03a6f73b27e9c4f0320d15da1f9d5 /gnu/packages/groff.scm
parent6c4a951a6e8f63c683dd7aca0651cd482ee2f3d3 (diff)
downloadguix-patches-73b2ce87956b0d9168dcfa234128b91e0e41a4c7.tar
guix-patches-73b2ce87956b0d9168dcfa234128b91e0e41a4c7.tar.gz
gnu: groff-minimal: Disable relocatability.
* gnu/packages/groff.scm (groff-minimal)[arguments]<#:phases> [disable-relocatability]: New phase.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 77728a5d78..cf392f5468 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -96,6 +96,36 @@ is usually the formatter of \"man\" documentation pages.")
,@(substitute-keyword-arguments (package-arguments groff)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'disable-relocatability
+ (lambda _
+ ;; Groff contains a Rube Goldberg-esque relocator for the
+ ;; file "charset.alias".
+ ;; It tries to find the current executable using realpath,
+ ;; a do-it-yourself search in $PATH and so on.
+ ;; Furthermore, the routine that does the search is buggy
+ ;; in that it doesn't handle error cases when they arise.
+ ;; This causes preconv to segfault when trying to look up
+ ;; the file "charset.alias" in the NULL location.
+ ;; The "charset.alias" parser is a copy of gnulib's, and a
+ ;; non-broken version of gnulib's "charset.alias" parser
+ ;; is part of glibc's libcharset.
+ ;; However, groff unconditionally uses their own
+ ;; "charset.alias" parser, but then DOES NOT INSTALL the
+ ;; file "charset.alias" when glibc is too new.
+ ;; In Guix, our file "charset.alias" only contains an
+ ;; obscure alias for ASCII and nothing else.
+ ;; So just disable relocation and make the entire
+ ;; "charset.alias" lookup fail.
+ ;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=30785>
+ ;; for details.
+ (substitute* "src/libs/libgroff/Makefile.sub"
+ (("-DENABLE_RELOCATABLE=1") ""))
+ ;; That file contains a crash bug--so make sure that
+ ;; its contents are not there.
+ (call-with-output-file "src/libs/libgroff/relocate.cpp"
+ (lambda (port)
+ #t))
+ #t))
(add-after 'install 'remove-non-essential-programs
(lambda* (#:key outputs #:allow-other-keys)
;; Keep only the programs that man-db needs at run time,