summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-08-04 21:45:24 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-05 11:34:35 +0200
commit519fe9d61f768cb5235921071f293d729413ebc5 (patch)
treed4b4be1070d7d49e81bb3200106a98305dbbc9bb /gnu/packages/groff.scm
parentc1baf5a917e87533550627b2f10f286576355e80 (diff)
downloadguix-patches-519fe9d61f768cb5235921071f293d729413ebc5.tar
guix-patches-519fe9d61f768cb5235921071f293d729413ebc5.tar.gz
gnu: roffit: Update to 0.12.
* gnu/packages/groff.scm (roffit): Update to 0.12. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index ae896cf9fd..222b4cb6dc 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +35,8 @@
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages perl)
- #:use-module (gnu packages texinfo))
+ #:use-module (gnu packages texinfo)
+ #:use-module (gnu packages web))
(define-public groff
(package
@@ -169,11 +171,11 @@ is usually the formatter of \"man\" documentation pages.")
;; There are no releases, so we take the latest commit.
(define-public roffit
- (let ((commit "e5228388e3faf2b7f1ae5bd048ad46ed565304c6")
+ (let ((commit "b59e6c855ebea03daf76e996b5c0f8343f11be3d")
(revision "1"))
(package
(name "roffit")
- (version (string-append "0.11-" revision "." (string-take commit 9)))
+ (version (string-append "0.12-" revision "." (string-take commit 9)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -182,7 +184,7 @@ is usually the formatter of \"man\" documentation pages.")
(file-name (string-append "roffit-" commit "-checkout"))
(sha256
(base32
- "1y7ndbqciy7h0khlpi1bv4v1614vhybnmm4jysj6fwxkw9cwv1nc"))))
+ "0z4cs92yqh22sykfgbjlyxfaifdvsd47cf1yhr0f2rgcc6l0fj1r"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -197,6 +199,7 @@ is usually the formatter of \"man\" documentation pages.")
(mkdir-p (string-append (assoc-ref outputs "out")
"/bin"))
#t)))))
+ (native-inputs `(("html-tree" ,perl-html-tree))) ; for test
(inputs
`(("perl" ,perl)))
(home-page "https://daniel.haxx.se/projects/roffit/")