summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-24 11:12:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-25 22:02:39 +0100
commit33ca5517316e68771f6195a1f7801e94a6c7bfe7 (patch)
tree24f8d8e3f6eccedcec6475af545a053caba77b63 /gnu/packages/groff.scm
parentf077aa2b29759eb1ecabc5b7e764b1d51ad05b5c (diff)
downloadguix-patches-33ca5517316e68771f6195a1f7801e94a6c7bfe7.tar
guix-patches-33ca5517316e68771f6195a1f7801e94a6c7bfe7.tar.gz
gnu: Add roffit.
* gnu/packages/groff.scm (roffit): New variable.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 93d0380595..e7a6fbda15 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages bison)
@@ -56,3 +58,42 @@ formatted output based on formatting commands contained within the text. It
is usually the formatter of \"man\" documentation pages.")
(license gpl3+)
(home-page "http://www.gnu.org/software/groff/")))
+
+;; There are no releases, so we take the latest commit.
+(define-public roffit
+ (let ((commit "e5228388e3faf2b7f1ae5bd048ad46ed565304c6")
+ (revision "1"))
+ (package
+ (name "roffit")
+ (version (string-append "0.11-" revision "." (string-take commit 9)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bagder/roffit.git")
+ (commit commit)))
+ (file-name (string-append "roffit-" commit "-checkout"))
+ (sha256
+ (base32
+ "1y7ndbqciy7h0khlpi1bv4v1614vhybnmm4jysj6fwxkw9cwv1nc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags
+ (list (string-append "INSTALLDIR="
+ (assoc-ref %outputs "out") "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'pre-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out")
+ "/bin"))
+ #t)))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "https://daniel.haxx.se/projects/roffit/")
+ (synopsis "Convert nroff files to HTML")
+ (description
+ "Roffit is a program that reads an nroff file and outputs an HTML file.
+It is typically used to display man pages on a web site.")
+ (license expat))))