summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-06 17:25:23 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-06 17:25:23 +0100
commit2ced84fbaee2f224cf2ef493ef6b0dc9839a1b13 (patch)
tree9faa0b145b7eddd01dba4277becacefe045ba113 /gnu/packages/groff.scm
parent1ccd060f2f86aeb179177b8203c1fb480669657e (diff)
downloadguix-patches-2ced84fbaee2f224cf2ef493ef6b0dc9839a1b13.tar
guix-patches-2ced84fbaee2f224cf2ef493ef6b0dc9839a1b13.tar.gz
gnu: groff-minimal: Inherit phases from groff.
* gnu/packages/groff.scm (groff-minimal)[arguments]: Use 'substitute-keyword-arguments' to prevent phases from "groff" overriding the phases in groff-minimal.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index fd098cd770..5f1b8d0ed6 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -22,6 +22,7 @@
(define-module (gnu packages groff)
#:use-module (guix licenses)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
@@ -92,32 +93,32 @@ is usually the formatter of \"man\" documentation pages.")
#:configure-flags '("--docdir=/tmp/trash/doc")
- #:phases (modify-phases %standard-phases
- (add-after 'install 'remove-non-essential-programs
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Keep only the programs that man-db needs at run time,
- ;; and make sure we don't pull in Perl.
- (let ((out (assoc-ref outputs "out"))
- (kept '("eqn" "neqn" "pic" "tbl" "refer"
- "nroff" "groff" "troff" "grotty")))
- (for-each (lambda (file)
- (unless (member (basename file) kept)
- (delete-file file)))
- (find-files (string-append out "/bin")))
+ ,@(substitute-keyword-arguments (package-arguments groff)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'remove-non-essential-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Keep only the programs that man-db needs at run time,
+ ;; and make sure we don't pull in Perl.
+ (let ((out (assoc-ref outputs "out"))
+ (kept '("eqn" "neqn" "pic" "tbl" "refer"
+ "nroff" "groff" "troff" "grotty")))
+ (for-each (lambda (file)
+ (unless (member (basename file) kept)
+ (delete-file file)))
+ (find-files (string-append out "/bin")))
- ;; Remove a bunch of unneeded Perl scripts.
- (for-each delete-file (find-files out "\\.pl$"))
- (for-each delete-file
- (find-files out "BuildFoundries"))
+ ;; Remove a bunch of unneeded Perl scripts.
+ (for-each delete-file (find-files out "\\.pl$"))
+ (for-each delete-file
+ (find-files out "BuildFoundries"))
- ;; Remove ~3 MiB from share/groff/X.Y/font/devBACKEND
- ;; corresponding to the unused backends.
- (for-each delete-file-recursively
- (find-files out "^dev(dvi|ps|pdf|html|lj4)$"
- #:directories? #t))
- #t))))
-
- ,@(package-arguments groff)))))
+ ;; Remove ~3 MiB from share/groff/X.Y/font/devBACKEND
+ ;; corresponding to the unused backends.
+ (for-each delete-file-recursively
+ (find-files out "^dev(dvi|ps|pdf|html|lj4)$"
+ #:directories? #t))
+ #t))))))))))
;; There are no releases, so we take the latest commit.
(define-public roffit