summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorGiacomo Leidi via Guix-patches via <guix-patches@gnu.org>2021-12-09 23:56:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-10 23:47:01 +0100
commitcfdf66e6bfc463b041965b64fc95174c90f046e0 (patch)
treef6c1a63bb96604222f7026f575b393c8ca8ec6cf /gnu/packages/graphviz.scm
parentf08ce1d9ce2407648cecfcf564f0769bd0100f49 (diff)
downloadguix-patches-cfdf66e6bfc463b041965b64fc95174c90f046e0.tar
guix-patches-cfdf66e6bfc463b041965b64fc95174c90f046e0.tar.gz
gnu: Add gprof2dot.
* gnu/packages/graphviz.scm (gprof2dot): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index ac896fb577..6d3bb292ac 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -456,3 +457,45 @@ This approach allows:
@item Using backend specific styles to customize the output
@end itemize")
(license license:expat)))
+
+(define-public gprof2dot
+ (package
+ (name "gprof2dot")
+ (version "2021.02.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jrfonseca/gprof2dot")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jjhsjf5fdi1fkn7mvhnzkh6cynl8gcjrygd3cya5mmda3akhzic"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "tests/test.py")))))))
+ (native-inputs
+ `(("graphviz" ,graphviz)))
+ (home-page "https://github.com/jrfonseca/gprof2dot")
+ (synopsis "Generate a dot graph from the output of several profilers")
+ (description "This package provides a Python script to convert the output
+from many profilers into a dot graph.
+
+It can:
+
+@itemize
+
+@item prune nodes and edges below a certain threshold;
+@item use an heuristic to propagate time inside mutually recursive functions;
+@item use color efficiently to draw attention to hot-spots;
+@item work on any platform where Python and Graphviz is available.
+
+@end itemize")
+ (license license:lgpl3+)))