summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-04-14 23:55:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-15 11:22:29 +0300
commitc578d7a25af52d2c35ee9baee97b6e4ab3095783 (patch)
tree61c5f4a9ef369b5e06609663bd5187d846f46a69 /gnu/packages/graphviz.scm
parent81b361fdd410d9318ab73cfd8e4742f82ad0ab96 (diff)
downloadguix-patches-c578d7a25af52d2c35ee9baee97b6e4ab3095783.tar
guix-patches-c578d7a25af52d2c35ee9baee97b6e4ab3095783.tar.gz
gnu: Add python-uqbar.
* gnu/packages/graphviz.scm (python-uqbar): New variable. Co-authored-by: jgart <jgart@dismail.de> Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index b5c4774d5c..eb3fd1d583 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Pjotr Prins <pjotr.guix@thebird.nl>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,7 +49,9 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tex)
@@ -242,6 +245,55 @@ structure and layout algorithms.")
(define-public python2-pygraphviz
(package-with-python2 python-pygraphviz))
+(define-public python-uqbar
+ (package
+ (name "python-uqbar")
+ (version "0.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/josiah-wolf-oberholtzer/uqbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0413nyhd8z8v3lvsgaghhafnyxg90fi1q80j1kbl21gpmpnc9a7n"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ ;; Latest versions of sphink-rtd-theme require npm to build.
+ (("sphinx-rtd-theme >= 0.4.0") "sphinx-rtd-theme >= 0.2.4")
+ (("black == 19.10b0") "black >= 19.10b0"))
+ #t))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "tests"))
+ #t)))))
+ (native-inputs
+ `(("graphviz" ,graphviz)
+ ("python-flake8" ,python-flake8)
+ ("python-isort" ,python-isort)
+ ("python-mypy" ,python-mypy)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (propagated-inputs
+ `(("python-black" ,python-black)
+ ("python-sphinx" ,python-sphinx)
+ ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
+ ("python-unidecode" ,python-unidecode)))
+ (home-page "https://github.com/josiah-wolf-oberholtzer/uqbar")
+ (synopsis "Tools for building documentation with Sphinx, Graphviz and LaTeX")
+ (description
+ "This package contains tools for building documentation with Sphinx,
+Graphviz and LaTeX.")
+ (license license:expat)))
+
(define-public gts
(package
(name "gts")