summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-12-31 14:48:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-13 10:07:06 +0100
commit8b1c0dab45b35a811ea53761368d1a29997350e3 (patch)
tree5588b0dc9fd5a33b84864e18b94b5ee5bac35c4f /gnu/packages/graphviz.scm
parent9e7f55de45612c7373b15df28aae6316a50fd583 (diff)
downloadguix-patches-8b1c0dab45b35a811ea53761368d1a29997350e3.tar
guix-patches-8b1c0dab45b35a811ea53761368d1a29997350e3.tar.gz
gnu: Add python-pygraphviz.
* gnu/packages/graphviz.scm (python-pygraphviz): New variable.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 47342b784d..42f793b488 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -29,6 +29,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (gnu packages check)
#:use-module (gnu packages xorg)
#:use-module (gnu packages flex)
#:use-module (gnu packages gtk)
@@ -186,6 +187,40 @@ visualization tool suite.")
(define-public python2-graphviz
(package-with-python2 python-graphviz))
+(define-public python-pygraphviz
+ (package
+ (name "python-pygraphviz")
+ (version "1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pygraphviz/pygraphviz.git")
+ (commit (string-append "pygraphviz-" version))))
+ (file-name (string-append "pygraphviz-" version "-checkout"))
+ (sha256
+ (base32
+ "1yldym38m8ckgflln83i88143pd9fjj1vfp23sq39fs6np5g0nzp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:configure-flags
+ (let ((graphviz (assoc-ref %build-inputs "graphviz")))
+ (list (string-append "--include-path=" graphviz "/include")
+ (string-append "--library-path=" graphviz "/lib")))))
+ (inputs
+ `(("graphviz" ,graphviz-2.38)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-mock" ,python-mock)
+ ("python-doctest-ignore-unicode" ,python-doctest-ignore-unicode)))
+ (home-page "http://pygraphviz.github.io")
+ (synopsis "Python interface to Graphviz")
+ (description "PyGraphviz is a Python interface to the Graphviz graph
+layout and visualization package. With PyGraphviz you can create, edit, read,
+write, and draw graphs using Python to access the Graphviz graph data
+structure and layout algorithms.")
+ (license license:bsd-3)))
+
(define-public gts
(package
(name "gts")