summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/graphviz.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm87
1 files changed, 39 insertions, 48 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 19a777fec9..c4dfd4965b 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -116,9 +116,7 @@
("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)))
(native-inputs
- `(("bison" ,bison)
- ("swig" ,swig)
- ("pkg-config" ,pkg-config)))
+ (list bison swig pkg-config))
(outputs '("out" "doc")) ; 5 MiB of html + pdfs
(home-page "https://www.graphviz.org/")
(synopsis "Graph visualization software")
@@ -167,13 +165,13 @@ interfaces for other technical domains.")
(lambda _
(invoke (which "sh") "autogen.sh" "NOCONFIG") #t))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("flex" ,flex)
- ("perl" ,perl)
- ("tcl" ,tcl)
- ,@(package-native-inputs graphviz))))))
+ (modify-inputs (package-native-inputs graphviz)
+ (prepend autoconf
+ automake
+ libtool
+ flex
+ perl
+ tcl))))))
(define-public python-graphviz
(package
@@ -195,14 +193,13 @@ interfaces for other technical domains.")
(format #t "test suite not run~%"))
#t)))))
(native-inputs
- `(("unzip" ,unzip)
-
- ;; For tests.
- ("graphviz" ,graphviz)
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-mock" ,python-pytest-mock)))
+ (list unzip
+ ;; For tests.
+ graphviz
+ python-mock
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock))
(home-page "https://github.com/xflr6/graphviz")
(synopsis "Simple Python interface for Graphviz")
(description
@@ -229,12 +226,10 @@ visualization tool suite.")
"0jqc3dzy9n0hn3b99zq8jp53901zpjzvvi5ns5mbaxg8kdrb1lfx"))))
(build-system python-build-system)
(inputs
- `(("graphviz" ,graphviz)))
+ (list graphviz))
(native-inputs
- `(("python-nose" ,python-nose)
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-doctest-ignore-unicode" ,python-doctest-ignore-unicode)))
+ (list python-nose python-mock python-pytest
+ python-doctest-ignore-unicode))
(home-page "https://pygraphviz.github.io")
(synopsis "Python interface to Graphviz")
(description "PyGraphviz is a Python interface to the Graphviz graph
@@ -274,17 +269,15 @@ structure and layout algorithms.")
(invoke "python" "-m" "pytest" "tests"))
#t)))))
(native-inputs
- `(("graphviz" ,graphviz)
- ("python-flake8" ,python-flake8)
- ("python-isort" ,python-isort)
- ("python-mypy" ,python-mypy)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)))
+ (list graphviz
+ python-flake8
+ python-isort
+ python-mypy
+ python-pytest
+ python-pytest-cov))
(propagated-inputs
- `(("python-black" ,python-black)
- ("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
- ("python-unidecode" ,python-unidecode)))
+ (list python-black python-sphinx python-sphinx-rtd-theme
+ python-unidecode))
(home-page "https://github.com/josiah-wolf-oberholtzer/uqbar")
(synopsis "Tools for building documentation with Sphinx, Graphviz and LaTeX")
(description
@@ -316,10 +309,10 @@ Graphviz and LaTeX.")
;; See <http://sourceforge.net/p/gts/bugs/41/>.
#:tests? #f))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(propagated-inputs
;; The gts.pc file has glib-2.0 as required.
- `(("glib" ,glib)))
+ (list glib))
(home-page "http://gts.sourceforge.net/")
;; Note: Despite the name, this is not official GNU software.
@@ -357,12 +350,12 @@ Graphviz and LaTeX.")
`("PATH" ":" prefix
(,(dirname (search-input-file inputs "bin/dot"))))))))))
(inputs
- `(("atk" ,atk)
- ("librsvg" ,librsvg)
- ("graphviz" ,graphviz)
- ("gtk+" ,gtk+)
- ("python-pycairo" ,python-pycairo)
- ("python-pygobject" ,python-pygobject)))
+ (list atk
+ librsvg
+ graphviz
+ gtk+
+ python-pycairo
+ python-pygobject))
(home-page "https://pypi.org/project/xdot/")
(synopsis "Interactive viewer for graphviz dot files")
(description "Xdot is an interactive viewer for graphs written in
@@ -397,10 +390,9 @@ can be used either as a standalone application, or as a Python library.")
#t)))))
(native-inputs
;; For tests.
- `(("graphviz" ,graphviz)
- ("python-chardet" ,python-chardet)))
+ (list graphviz python-chardet))
(propagated-inputs
- `(("python-pyparsing" ,python-pyparsing)))
+ (list python-pyparsing))
(home-page "https://github.com/pydot/pydot")
(synopsis "Python interface to Graphviz's DOT language")
(description
@@ -425,10 +417,9 @@ graphs in Graphviz's DOT language, written in pure Python.")
(arguments
`(#:python ,python-2))
(inputs
- `(("texlive-latex-preview" ,texlive-latex-preview)
- ("graphviz" ,graphviz)))
+ (list texlive-latex-preview graphviz))
(propagated-inputs
- `(("python-pyparsing" ,python2-pyparsing)))
+ (list python2-pyparsing))
(home-page "https://github.com/kjellmf/dot2tex")
(synopsis "Graphviz to LaTeX converter")
(description
@@ -468,7 +459,7 @@ This approach allows:
(add-installed-pythonpath inputs outputs)
(invoke "python" "tests/test.py")))))))
(native-inputs
- `(("graphviz" ,graphviz)))
+ (list graphviz))
(home-page "https://github.com/jrfonseca/gprof2dot")
(synopsis "Generate a dot graph from the output of several profilers")
(description "This package provides a Python script to convert the output