summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-07-29 10:23:52 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-29 10:23:52 +0200
commit370cb92eaa089af19c08d9a7b4f5a96ac5b27716 (patch)
tree0f4d6ab4fb36cc3307a2bf9fa35f6cf84d5c3a77 /gnu/packages/graphviz.scm
parentb4c86e6dbc828288fec8966f05d2291d78055525 (diff)
downloadguix-patches-370cb92eaa089af19c08d9a7b4f5a96ac5b27716.tar
guix-patches-370cb92eaa089af19c08d9a7b4f5a96ac5b27716.tar.gz
gnu: python-pygraphviz: Update to 1.7.
* gnu/packages/graphviz.scm (python-pygraphviz): Update to 1.7. [arguments]: Remove #:configure-flags that are no longer supported. [inputs]: Use the latest graphviz package. [native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index dbfc66960e..ed8f55b9d9 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -214,7 +214,7 @@ visualization tool suite.")
(define-public python-pygraphviz
(package
(name "python-pygraphviz")
- (version "1.5")
+ (version "1.7")
(source
(origin
(method git-fetch)
@@ -224,18 +224,14 @@ visualization tool suite.")
(file-name (string-append "pygraphviz-" version "-checkout"))
(sha256
(base32
- "1yldym38m8ckgflln83i88143pd9fjj1vfp23sq39fs6np5g0nzp"))))
+ "0jqc3dzy9n0hn3b99zq8jp53901zpjzvvi5ns5mbaxg8kdrb1lfx"))))
(build-system python-build-system)
- (arguments
- `(#:configure-flags
- (let ((graphviz (assoc-ref %build-inputs "graphviz")))
- (list (string-append "--include-path=" graphviz "/include")
- (string-append "--library-path=" graphviz "/lib")))))
(inputs
- `(("graphviz" ,graphviz-2.38)))
+ `(("graphviz" ,graphviz)))
(native-inputs
`(("python-nose" ,python-nose)
("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
("python-doctest-ignore-unicode" ,python-doctest-ignore-unicode)))
(home-page "https://pygraphviz.github.io")
(synopsis "Python interface to Graphviz")