summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 15:57:12 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 20:08:24 +0200
commite0bb6391a9bd55f3856fa45f23a7891d29b834ad (patch)
tree6f10a3658a4e4ca7c88fa2b7baab0266bd8928eb /gnu/packages/graphics.scm
parentea60beeb3d36a7fe1d8df57bd9981b98c179b19c (diff)
downloadguix-patches-e0bb6391a9bd55f3856fa45f23a7891d29b834ad.tar
guix-patches-e0bb6391a9bd55f3856fa45f23a7891d29b834ad.tar.gz
gnu: ilmbase: Update to 2.5.2.
* gnu/packages/patches/ilmbase-fix-test-arm.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/graphics.scm (ilmbase): Update to 2.5.2. [source](patches): Remove 'ilmbase-fix-test-arm.patch'. (openexr)[arguments]: Really increase test timeout, as the previous fix was ineffective.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 0d768b8a0e..e8bff9b86a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -359,7 +359,7 @@ many more.")
(define-public ilmbase
(package
(name "ilmbase")
- (version "2.5.0")
+ (version "2.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -368,9 +368,8 @@ many more.")
(file-name (git-file-name "ilmbase" version))
(sha256
(base32
- "1k50cvi3sk6gf6w713lkk2gv5cvs74vkc7s7k4z6nmyhi4g89w4y"))
- (patches (search-patches "ilmbase-fix-tests.patch"
- "ilmbase-fix-test-arm.patch"))))
+ "1vf8bqld2bpcdi99jbr043y6vp01cp3fvbiasrn66xn91mf6imbn"))
+ (patches (search-patches "ilmbase-fix-tests.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -589,11 +588,15 @@ graphics.")
(lambda _
(chdir "OpenEXR")
#t))
- (add-before 'check 'increase-test-timeout
+ (add-after 'change-directory 'increase-test-timeout
(lambda _
;; On armhf-linux, we need to override the CTest default
;; timeout of 1500 seconds for the OpenEXR.IlmImf test.
- (setenv "CTEST_TEST_TIMEOUT" "2000")
+ (substitute* "IlmImfTest/CMakeLists.txt"
+ (("add_test\\(NAME OpenEXR\\.IlmImf.*" all)
+ (string-append
+ all
+ "set_tests_properties(OpenEXR.IlmImf PROPERTIES TIMEOUT 2000)")))
#t))
,@(if (not (target-64bit?))
`((add-after 'change-directory 'disable-broken-test