summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-14 14:43:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-14 14:45:47 +0200
commitdf8ab77450b24c02ff075acda79826e3099f78e7 (patch)
treed3ef20d7ecaeee8ef0bc69aa73f2225c106eeefa /gnu/packages/graphics.scm
parentcabe8f18443a0a1deb6f2ae7d8f4a6fb591daceb (diff)
downloadguix-patches-df8ab77450b24c02ff075acda79826e3099f78e7.tar
guix-patches-df8ab77450b24c02ff075acda79826e3099f78e7.tar.gz
gnu: Add openscenegraph-3.4.
* gnu/packages/graphics.scm (openscenegraph-3.4): New variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 25c9e0b476..f9baf49fe9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -538,6 +538,32 @@ virtual reality, scientific visualization and modeling.")
;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
(license license:lgpl2.1)))
+;; We need this for simgear
+(define-public openscenegraph-3.4
+ (package (inherit openscenegraph)
+ (name "openscenegraph")
+ (version "3.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openscenegraph/OpenSceneGraph")
+ (commit (string-append "OpenSceneGraph-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fbzg1ihjpxk6smlq80p3h3ggllbr16ihd2fxpfwzam8yr8yxip9"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments openscenegraph)
+ ((#:configure-flags flags)
+ `(cons
+ ;; The jpeg plugin requires conversion between integers and booleans
+ "-DCMAKE_CXX_FLAGS=-fpermissive"
+ ,flags))))
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ,@(package-inputs openscenegraph)))))
+
(define-public povray
(package
(name "povray")