summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-28 09:33:34 +0100
committerEfraim Flashner <efraim@flashner.co.il>2019-03-28 12:14:15 +0200
commitd5640c587f141ff60127848dc95528ca1a4f1b14 (patch)
treecf77a07aca2f188dded4a5d7e0fbbc9e5a7ffaea /gnu/packages/graphics.scm
parentd98fb5603bd6fe9a7a7079aa143397465cb5d923 (diff)
downloadguix-patches-d5640c587f141ff60127848dc95528ca1a4f1b14.tar
guix-patches-d5640c587f141ff60127848dc95528ca1a4f1b14.tar.gz
gnu: googletest: Don't use unstable tarball.
* gnu/packages/check.scm (googletest)[source]: Download using git-fetch. * gnu/packages/crypto.scm (encfs)[arguments]: Adjust accordingly. * gnu/packages/gnucash.scm (gnucash)[arguments]: Same. * gnu/packages/terminals.scm (eternalterminal)[arguments]: Same. * gnu/packages/graphics.scm (ogre)[arguments]: Same. Remove now unnecessary custom 'pre-build phase.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 11158bdfd1..e4a6ee8476 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -366,21 +366,10 @@ exception-handling library.")
'(#:phases
(modify-phases %standard-phases
(add-before 'configure 'pre-configure
- (lambda _
- ;; It expects googletest source to be downloaded and
- ;; be in a specific place.
- (substitute* "Tests/CMakeLists.txt"
- (("URL(.*)$" _ suffix)
- (string-append "URL " suffix
- "\t\tURL_HASH "
- "MD5=16877098823401d1bf2ed7891d7dce36\n")))
- #t))
- (add-before 'build 'pre-build
(lambda* (#:key inputs #:allow-other-keys)
- (copy-file (assoc-ref inputs "googletest-source")
- (string-append (getcwd)
- "/Tests/googletest-prefix/src/"
- "release-1.8.0.tar.gz"))
+ (substitute* "Tests/CMakeLists.txt"
+ (("URL(.*)$")
+ (string-append "URL " (assoc-ref inputs "googletest-source"))))
#t)))
#:configure-flags
(list "-DOGRE_BUILD_TESTS=TRUE"