summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2021-01-13 14:45:39 -0500
committerLeo Famulari <leo@famulari.name>2021-01-16 15:40:34 -0500
commitc544cfb399b6d142052a546511af4da07b833662 (patch)
treea8c555db0e4aae025dd63ca7b012ca00860cb7c1 /gnu/packages/graphics.scm
parent225c5ea014728b03cc521481af7af284746cd464 (diff)
downloadguix-patches-c544cfb399b6d142052a546511af4da07b833662.tar
guix-patches-c544cfb399b6d142052a546511af4da07b833662.tar.gz
gnu: Add embree.
* gnu/packages/graphics.scm (embree): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9879130e20..84dcf16d2a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -428,6 +428,36 @@ with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
(license (list license:gpl2+ ;for the utility itself
license:lgpl2.1+))))) ;for use as a library
+(define-public embree
+ (package
+ (name "embree")
+ (version "3.12.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/embree/embree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aznd16n7h8g3f6jcahzfp1dq4r7wayqvn03wsaskiq2dvsi4srd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests (apparently)
+ #:configure-flags
+ (list
+ "-DEMBREE_ISPC_SUPPORT=OFF")))
+ (inputs
+ `(("tbb" ,tbb)
+ ("glfw" ,glfw)))
+ (home-page "https://www.embree.org/")
+ (synopsis "High performance ray tracing kernels")
+ (description
+ "Embree is a collection of high-performance ray tracing kernels.
+Embree is meant to increase performance of photo-realistic rendering
+applications.")
+ (license license:asl2.0)))
+
(define-public blender
(package
(name "blender")