summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-23 12:17:59 +0000
committerLeo Famulari <leo@famulari.name>2021-10-23 16:22:06 -0400
commitae3fa855f38bd3952e2cf510bbb58bbe74aeb3f8 (patch)
treec07bbbbedc865bc85ea323fa226bfc7b47fef224 /gnu/packages/graphics.scm
parent38db6e10f020c305bfc6e459dc2cf2a6ad444f91 (diff)
downloadguix-patches-ae3fa855f38bd3952e2cf510bbb58bbe74aeb3f8.tar
guix-patches-ae3fa855f38bd3952e2cf510bbb58bbe74aeb3f8.tar.gz
gnu: Add imath.
* gnu/packages/graphics.scm (imath): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9a5e2f2195..c285d781fe 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -796,6 +797,28 @@ many more.")
;; permissive licenses.
(license license:gpl3+)))
+(define-public imath
+ (package
+ (name "imath")
+ (version "3.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AcademySoftwareFoundation/Imath")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nyld18mf220ghm1vidnfnn0rdns9z5i4l9s66xgd0kfdgarb31f"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/AcademySoftwareFoundation/Imath")
+ (synopsis "Library of math operations for computer graphics")
+ (description
+ "Imath is a C++ representation of 2D and 3D vectors and matrices and other
+mathematical objects, functions, and data types common in computer graphics
+applications, including the \"half\" 16-bit floating-point type.")
+ (license license:bsd-3)))
+
(define-public ilmbase
(package
(name "ilmbase")