summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2021-04-26 16:58:47 +0200
committerLeo Famulari <leo@famulari.name>2021-05-03 13:04:55 -0400
commit9ffa81fe64ee405e1a861b72a21bca966fcbc236 (patch)
treef9db0ae8a314a97255dc300e67b4686964c804ac /gnu/packages/graphics.scm
parent88156c603a96a0d1c6de666dec9f3cb8864f3dc8 (diff)
downloadguix-patches-9ffa81fe64ee405e1a861b72a21bca966fcbc236.tar
guix-patches-9ffa81fe64ee405e1a861b72a21bca966fcbc236.tar.gz
gnu: blender: Update to 2.92.0.
* gnu/packages/graphics.scm (blender): Update to 2.92.0. [arguments]: Set the NumPy header include path in #:configure-flags. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ef3be67b25..2c25c5405b 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -503,14 +503,14 @@ typically encountered in feature film production.")
(define-public blender
(package
(name "blender")
- (version "2.91.0")
+ (version "2.92.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
"blender-" version ".tar.xz"))
(sha256
(base32
- "0x396lgmk0dq9115yrc36s8zwxzmjr490sr5n2y6w27y17yllyjm"))))
+ "15a5vffn18a920286x0avbc2rap56k6y531wgibq68r90g2cz4g7"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -536,6 +536,9 @@ typically encountered in feature film production.")
(string-append "-DPYTHON_INCLUDE_DIR=" (assoc-ref %build-inputs "python")
"/include/python" ,python-version)
(string-append "-DPYTHON_VERSION=" ,python-version)
+ (string-append "-DPYTHON_NUMPY_INCLUDE_DIRS="
+ (assoc-ref %build-inputs "python-numpy")
+ "/lib/python" ,python-version "/site-packages/numpy/core/include/")
(string-append "-DPYTHON_NUMPY_PATH="
(assoc-ref %build-inputs "python-numpy")
"/lib/python" ,python-version "/site-packages/"))