summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-24 23:23:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-24 23:25:49 +0200
commit9b91fb32f8c7b1bcd910d2d4baa6eeba172764f7 (patch)
tree3cbc2f9140aeffbfd748a5ca8508bcae3896da3d /gnu/packages/graphics.scm
parentff51a87cae360334ed42c79c3e4e46fb7c121eb2 (diff)
downloadguix-patches-9b91fb32f8c7b1bcd910d2d4baa6eeba172764f7.tar
guix-patches-9b91fb32f8c7b1bcd910d2d4baa6eeba172764f7.tar.gz
gnu: brdf-explorer: Update to 1.0.0-1.5b2cd46f3.
* gnu/packages/graphics.scm (brdf-explorer): Update to 1.0.0-1.5b2cd46f3. [source]: Use git-fetch method. [arguments]: Adjust configure phase. [native-inputs]: Replace qt with qttools. [inputs]: Replace qt with qtbase.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm106
1 files changed, 53 insertions, 53 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a502f246ff..cc1497cb8d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;;
@@ -23,7 +23,7 @@
(define-module (gnu packages graphics)
#:use-module (guix download)
- #:use-module (guix svn-download)
+ #:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
@@ -423,66 +423,66 @@ output.")
(license (license:non-copyleft "file://LICENSE"))))
(define-public brdf-explorer
- (package
- (name "brdf-explorer")
- (version "17") ;svn revision
- (source (origin
- ;; There are no release tarballs, and not even tags in the repo,
- ;; so use the latest revision.
- (method svn-fetch)
- (uri (svn-reference
- (url "https://github.com/wdas/brdf")
- (revision (string->number version))))
- (sha256
- (base32
- "1458fwsqxramh0gpnp24x7brfpl9afhvr1wqg6c78xqwf32960m5"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (chdir "trunk")
- (zero? (system* "qmake"
- (string-append
- "prefix=" out))))))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (data (string-append
- out "/share/brdf")))
- (with-directory-excursion bin
- (rename-file "brdf" ".brdf-real")
- (call-with-output-file "brdf"
- (lambda (port)
- (format port "#!/bin/sh
+ ;; There are no release tarballs, and not even tags in the repo,
+ ;; so use the latest revision.
+ (let ((commit "5b2cd46f38a06e47207fa7229b72d37beb945019")
+ (revision "1"))
+ (package
+ (name "brdf-explorer")
+ (version (string-append "1.0.0-" revision "." (string-take commit 9)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wdas/brdf.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "06vzbiajzbi2xl8jlff5d45bc9wd68i3jdndfab1f3jgfrd8bsgx"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "qmake"
+ (string-append "prefix=" out))))))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (data (string-append
+ out "/share/brdf")))
+ (with-directory-excursion bin
+ (rename-file "brdf" ".brdf-real")
+ (call-with-output-file "brdf"
+ (lambda (port)
+ (format port "#!/bin/sh
# Run the thing from its home, otherwise it just bails out.
cd \"~a\"
exec -a \"$0\" ~a/.brdf-real~%"
- data bin)))
- (chmod "brdf" #o555))))))))
- (native-inputs
- `(("qt" ,qt-4))) ;for 'qmake'
- (inputs
- `(("qt" ,qt-4)
- ("mesa" ,mesa)
- ("glew" ,glew)
- ("freeglut" ,freeglut)
- ("zlib" ,zlib)))
- (home-page "http://www.disneyanimation.com/technology/brdf.html")
- (synopsis
- "Analyze bidirectional reflectance distribution functions (BRDFs)")
- (description
- "BRDF Explorer is an application that allows the development and analysis
+ data bin)))
+ (chmod "brdf" #o555))))))))
+ (native-inputs
+ `(("qttools" ,qttools))) ;for 'qmake'
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("mesa" ,mesa)
+ ("glew" ,glew)
+ ("freeglut" ,freeglut)
+ ("zlib" ,zlib)))
+ (home-page "http://www.disneyanimation.com/technology/brdf.html")
+ (synopsis
+ "Analyze bidirectional reflectance distribution functions (BRDFs)")
+ (description
+ "BRDF Explorer is an application that allows the development and analysis
of bidirectional reflectance distribution functions (BRDFs). It can load and
plot analytic BRDF functions (coded as functions in OpenGL's GLSL shader
language), measured material data from the MERL database, and anisotropic
measured material data from MIT CSAIL. Graphs and visualizations update in
real time as parameters are changed, making it a useful tool for evaluating
and understanding different BRDFs (and other component functions).")
- (license license:ms-pl)))
+ (license license:ms-pl))))
(define-public agg
(package