summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-23 17:15:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-24 20:12:56 +0200
commit942c7889498fc8e680a16d500e166c9ade84e640 (patch)
treeba82db572d0c84fa79a34d79c26545352852a15d /gnu/packages/graphics.scm
parentd8fbfbf52363333b5f925a52edc4e5bbc85c45de (diff)
downloadguix-patches-942c7889498fc8e680a16d500e166c9ade84e640.tar
guix-patches-942c7889498fc8e680a16d500e166c9ade84e640.tar.gz
gnu: OpenEXR: Update to 2.4.0 [fixes CVE-2018-18443, CVE-2018-18444].
* gnu/packages/patches/ilmbase-fix-tests.patch: Adjust for new origin. * gnu/packages/patches/ilmbase-openexr-pkg-config.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/graphics.scm (ilmbase): Update to 2.4.0. [source]: Change to GIT-FETCH, as tarballs are no longer provided. Add new patch. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add phase to enter the correct source directory. * gnu/packages/graphics.scm (openexr): Update to 2.4.0. [source]: Inherit from ILMBASE, which comes from the same repository. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add phase to enter the correct source directory. * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Enable C++11. * gnu/packages/image-processing.scm (opencv)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm46
1 files changed, 27 insertions, 19 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d4e9adb84a..795e750cb5 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -327,17 +328,25 @@ many more.")
(define-public ilmbase
(package
(name "ilmbase")
- (version "2.3.0")
+ (version "2.4.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openexr/openexr/releases"
- "/download/v" version "/ilmbase-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openexr/openexr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "ilmbase" version))
(sha256
(base32
- "0qiq5bqq9rxhqjiym2k36sx4vq8adgrz6xf6qwizi9bqm78phsa5"))
- (patches (search-patches "ilmbase-fix-tests.patch"))))
- (build-system gnu-build-system)
+ "0g3rz11cvb7gnphp2np9z7bfl7v4dprq4w5hnsvx7yrasgsdyn8s"))
+ (patches (search-patches "ilmbase-fix-tests.patch"
+ "ilmbase-openexr-pkg-config.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "IlmBase")
+ #t)))))
(home-page "http://www.openexr.com/")
(synopsis "Utility C++ libraries for threads, maths, and exceptions")
(description
@@ -409,27 +418,26 @@ graphics.")
(define-public openexr
(package
(name "openexr")
- (version "2.3.0")
+ (version (package-version ilmbase))
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openexr/openexr/releases"
- "/download/v" version "/openexr-"
- version ".tar.gz"))
- (sha256
- (base32
- "19jywbs9qjvsbkvlvzayzi81s976k53wg53vw4xj66lcgylb6v7x"))
+ (inherit (package-source ilmbase))
+ (file-name (git-file-name "openexr" version))
(modules '((guix build utils)))
(snippet
'(begin
- (substitute* (find-files "." "tmpDir\\.h")
+ (substitute* (find-files "OpenEXR" "tmpDir\\.h")
(("\"/var/tmp/\"")
"\"/tmp/\""))
#t))))
- (build-system gnu-build-system)
+ (build-system cmake-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-test
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "OpenEXR")
+ #t))
+ (add-after 'change-directory 'disable-broken-test
;; This test fails on i686. Upstream developers suggest that
;; this test is broken on i686 and can be safely disabled:
;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748