summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-10 00:05:11 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:26:18 +0200
commit8d82df1376f50bb1e32fa82e943b0f5c837658b6 (patch)
treef9635fb1b790cfaabd969af7128420d6e7491d8e /gnu/packages/graphics.scm
parente7db21bd100370ae96c87c8b665587bea7035cbc (diff)
downloadguix-patches-8d82df1376f50bb1e32fa82e943b0f5c837658b6.tar
guix-patches-8d82df1376f50bb1e32fa82e943b0f5c837658b6.tar.gz
gnu: Add egl-wayland.
* gnu/packages/graphics.scm (egl-wayland): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ab4ebc4231..187aeff8a0 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -160,6 +160,36 @@ application-facing EGL functions.")
(home-page "https://github.com/NVIDIA/eglexternalplatform")
(license license:expat)))
+(define-public egl-wayland
+ (package
+ (name "egl-wayland")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/NVIDIA/egl-wayland.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "09r6a69z75j3hb9751g3ap4gm1xn71aw3j7z0c7jns292cnaa76n"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("mesa" ,mesa)
+ ("wayland" ,wayland)))
+ (propagated-inputs
+ `(("eglexternalplatform" ,eglexternalplatform)))
+ (synopsis "EGLStream-based Wayland external platform")
+ (description "EGL-Wayland is an implementation of a EGL External Platform
+library to add client-side Wayland support to EGL on top of EGLDevice and
+EGLStream families of extensions.")
+ (home-page "https://github.com/NVIDIA/egl-wayland")
+ (license license:expat)))
+
(define-public mmm
(package
(name "mmm")