summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-13 16:41:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-13 16:47:22 +0100
commit8ae17933e2bdffe21351cfa664ac9773125c674b (patch)
tree8f35e922253ea03ceb35a9dfc013fec69884253f /gnu/packages/graphics.scm
parentd81fb2ae9443994ae5dd1cb5837276fad63f842c (diff)
downloadguix-patches-8ae17933e2bdffe21351cfa664ac9773125c674b.tar
guix-patches-8ae17933e2bdffe21351cfa664ac9773125c674b.tar.gz
gnu: opensubdiv: Build with a newer version of Mesa.
* gnu/packages/gl.scm (mesa-19.3.3): New public variable. * gnu/packages/graphics.scm (opensubdiv)[inputs]: Add it.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4b6e57986c..bcdc372d86 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
@@ -1061,7 +1061,10 @@ requirements.")
(native-inputs
`(("xorg-server" ,xorg-server-for-tests)))
(inputs
- `(("glew" ,glew)
+ `(;; The test suite fails when using Mesa 19.3.2, so we provide this newer
+ ;; version. Remove this input when the 'mesa' package is updated.
+ ("mesa" ,mesa-19.3.3)
+ ("glew" ,glew)
("libxrandr" ,libxrandr)
("libxcursor" ,libxcursor)
("libxinerama" ,libxinerama)