summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-05 15:34:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-19 11:10:43 +0300
commit81b31ca8e1bb4c93e8910f1d3e2e0cf3e8435286 (patch)
tree9624563908ae96ec68171d815e5c39e93dd6776e /gnu/packages/graphics.scm
parent14f8d58752c2f44b039e4f3b6e7f094ecd0ff1dd (diff)
downloadguix-patches-81b31ca8e1bb4c93e8910f1d3e2e0cf3e8435286.tar
guix-patches-81b31ca8e1bb4c93e8910f1d3e2e0cf3e8435286.tar.gz
gnu: Add gr-framework.
* gnu/packages/graphics.scm (gr-framework): New variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3f2be5766c..9a5e2f2195 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1254,6 +1254,56 @@ virtual reality, scientific visualization and modeling.")
`(("libjpeg" ,libjpeg-turbo)
,@(package-inputs openscenegraph)))))
+(define-public gr-framework
+ (package
+ (name "gr-framework")
+ (version "0.58.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sciapp/gr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q1rz4iyxbh0dc22y4w28ry3hr0yypdwdm6pw2zlwgjya7wkbvsw"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "3rdparty")
+ #t))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test target
+ (inputs
+ `(("bzip2" ,bzip2)
+ ("cairo" ,cairo)
+ ("fontconfig" ,fontconfig)
+ ("ffmpeg" ,ffmpeg)
+ ("freetype" ,freetype)
+ ("ghostscript" ,ghostscript)
+ ("glfw" ,glfw)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("libxt" ,libxt)
+ ("pixman" ,pixman)
+ ("qtbase" ,qtbase-5)
+ ("qhull" ,qhull)
+ ("zlib" ,zlib)))
+ (home-page "https://gr-framework.org/")
+ (synopsis "Graphics library for visualisation applications")
+ (description "GR is a universal framework for cross-platform visualization
+applications. It offers developers a compact, portable and consistent graphics
+library for their programs. Applications range from publication quality 2D
+graphs to the representation of complex 3D scenes. GR is essentially based on
+an implementation of a @acronym{GKS, Graphical Kernel System}. As a
+self-contained system it can quickly and easily be integrated into existing
+applications (i.e. using the @code{ctypes} mechanism in Python or @code{ccall}
+in Julia).")
+ (license license:expat)))
(define-public openmw-openscenegraph
;; OpenMW prefers its own fork of openscenegraph: