summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-11-27 21:46:14 -0500
committerLeo Famulari <leo@famulari.name>2019-11-27 21:58:45 -0500
commit7297ebb28759b57db684be8cb4423e3221571401 (patch)
tree7c60d416e3e67663ab6949779383b6b8a89aa343 /gnu/packages/graphics.scm
parent9943d238e9f07dccae973b641eb7738637ce95fb (diff)
downloadguix-patches-7297ebb28759b57db684be8cb4423e3221571401.tar
guix-patches-7297ebb28759b57db684be8cb4423e3221571401.tar.gz
gnu: Blender: Update to 2.81.
* gnu/packages/graphics.scm (blender): Update to 2.81. [inputs]: Add libxi, libxrender, and tbb.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8795107dcb..3ef420cf05 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -71,6 +71,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages tbb)
#:use-module (gnu packages video)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -87,14 +88,14 @@
(define-public blender
(package
(name "blender")
- (version "2.80")
+ (version "2.81")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
- "blender-" version ".tar.gz"))
+ "blender-" version ".tar.xz"))
(sha256
(base32
- "1h550jisdbis50hxwk5kxrvrk1a6sh2fsri3yyj66vhzbi87x7fd"))))
+ "1prp0f2152f1sz23jlc86vndfvmplb7qhllikkirq7hgpykrshna"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -145,6 +146,8 @@
`(("boost" ,boost)
("jemalloc" ,jemalloc)
("libx11" ,libx11)
+ ("libxi" ,libxi)
+ ("libxrender" ,libxrender)
("openimageio" ,openimageio)
("openexr" ,openexr)
("opensubdiv" ,opensubdiv)
@@ -162,6 +165,7 @@
("openal" ,openal)
("python" ,python)
("python-numpy" ,python-numpy)
+ ("tbb" ,tbb)
("zlib" ,zlib)))
(home-page "https://blender.org/")
(synopsis "3D graphics creation suite")