summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-06-04 17:46:56 +0300
committerManolis Ragkousis <manolis837@gmail.com>2017-06-04 21:57:08 +0300
commit6bf11392f96c1667d6f5927b53caf5411fc0ed6e (patch)
treecf68f7f51735e81cfea291591c4fd80ad804986f /gnu/packages/graphics.scm
parentcc24bf98bd9b57e7f5653858c1a54283a490cbd0 (diff)
downloadguix-patches-6bf11392f96c1667d6f5927b53caf5411fc0ed6e.tar
guix-patches-6bf11392f96c1667d6f5927b53caf5411fc0ed6e.tar.gz
gnu: Add openscenegraph.
* gnu/packages/graphics.scm (openscenegraph): New variable. * gnu/packages/patches/openscenegraph-ffmpeg3.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index cc1497cb8d..90a2909ab2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages photo)
+ #:use-module (gnu packages pth)
#:use-module (gnu packages python)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -318,6 +320,47 @@ visual effects work for film.")
(home-page "http://www.openimageio.org")
(license license:bsd-3)))
+(define-public openscenegraph
+ (package
+ (name "openscenegraph")
+ (version "3.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://trac.openscenegraph.org/downloads/developer_releases/"
+ "OpenSceneGraph-" version ".zip"))
+ (sha256
+ (base32
+ "03h4wfqqk7rf3mpz0sa99gy715cwpala7964z2npd8jxfn27swjw"))
+ (patches (search-patches "openscenegraph-ffmpeg3.patch"))
+ (file-name (string-append name "-" version ".zip"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; No test target available.
+ #:configure-flags
+ (list (string-append "-DCMAKE_INSTALL_RPATH="
+ (assoc-ref %outputs "out") "/lib:"
+ (assoc-ref %outputs "out") "/lib64"))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("giflib", giflib)
+ ("jasper", jasper)
+ ("librsvg", librsvg)
+ ("pth", pth)
+ ("qtbase", qtbase)
+ ("ffmpeg", ffmpeg)
+ ("mesa", mesa)))
+ (synopsis "High performance real-time graphics toolkit")
+ (description
+ "The OpenSceneGraph is an open source high performance 3D graphics toolkit,
+used by application developers in fields such as visual simulation, games,
+virtual reality, scientific visualization and modelling.")
+ (home-page "http://www.openscenegraph.org")
+ ;; The 'LICENSE' file explains that the source is licensed under
+ ;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
+ (license license:lgpl2.1)))
+
(define-public rapicorn
(package
(name "rapicorn")