summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-08-02 20:32:22 +0300
committerManolis Ragkousis <manolis837@gmail.com>2017-08-03 10:35:31 +0300
commit5638d7150229bcc63bf26e484f81ff310dafd263 (patch)
treeb0c1bd88c399631b50474ea526b6a4a93bc2b6a8 /gnu/packages/graphics.scm
parent68a29ab8d00be37f5e084d16a8971d7cf5fb2714 (diff)
downloadguix-patches-5638d7150229bcc63bf26e484f81ff310dafd263.tar
guix-patches-5638d7150229bcc63bf26e484f81ff310dafd263.tar.gz
gnu: openscenegraph: Add 'Release' configure flag.
* gnu/packages/graphics.scm (openscenegraph)[arguments]: Add "-DCMAKE_BUILD_TYPE=Release".
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 6c813e8a37..d0e50106fa 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -339,7 +339,11 @@ visual effects work for film.")
#:configure-flags
(list (string-append "-DCMAKE_INSTALL_RPATH="
(assoc-ref %outputs "out") "/lib:"
- (assoc-ref %outputs "out") "/lib64"))))
+ (assoc-ref %outputs "out") "/lib64")
+ ;; We need to set this flag or otherwise 'rd' will be added
+ ;; to the name of the library binaries and break linking
+ ;; with other programs.
+ "-DCMAKE_BUILD_TYPE=Release")))
(native-inputs
`(("unzip" ,unzip)))
(inputs