summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-18 19:11:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-18 19:11:51 +0200
commit4b42b1067468dd7e5f3a5e11d64f16895bb16a25 (patch)
tree03d291e8f244b03a61b64fd25604393754309134 /gnu/packages/graphics.scm
parent25e491691b83a54552bb22113b951cf9fad18704 (diff)
downloadguix-patches-4b42b1067468dd7e5f3a5e11d64f16895bb16a25.tar
guix-patches-4b42b1067468dd7e5f3a5e11d64f16895bb16a25.tar.gz
gnu: openimageio: Fix build with Boost 1.70 and CMake 3.14.
* gnu/packages/graphics.scm (openimageio)[arguments]: Add <#:configure-flags>.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 94a797c8f5..2d9becc3ec 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -468,7 +468,11 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
;; FIXME: To run all tests successfully, test image sets from multiple
;; third party sources have to be present. For details see
;; https://github.com/OpenImageIO/oiio/blob/master/INSTALL
- (arguments `(#:tests? #f))
+ (arguments
+ `(#:tests? #f
+ ;; XXX: Work around a problem with Boost 1.70 and CMake 3.14. See
+ ;; <https://bugs.gnu.org/36721> for details.
+ #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs