summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-25 15:01:12 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-25 15:01:12 +0100
commit3d4c527824e4383ba1f7724e718ffb30148d69e2 (patch)
treeb6fbd7dc7722b3f7c892305f7adb555a71a725f0 /gnu/packages/graphics.scm
parentc9208beb3cbdd592275af28221cb93848b2a71a1 (diff)
downloadguix-patches-3d4c527824e4383ba1f7724e718ffb30148d69e2.tar
guix-patches-3d4c527824e4383ba1f7724e718ffb30148d69e2.tar.gz
gnu: lib2geom: Skip faulty test on i686.
* gnu/packages/graphics.scm (lib2geom)[arguments]: When 'target-x86-32?', add 'skip-faulty-test' phase.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 725cbc87ef..1c78bd7d5e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -812,7 +812,17 @@ exception-handling library.")
(substitute* '("src/cython/CMakeLists.txt"
"src/py2geom/CMakeLists.txt")
(("PYTHON_LIB_INSTALL \"[^\"]*\"")
- (format #f "PYTHON_LIB_INSTALL ~s" site-package)))))))))
+ (format #f "PYTHON_LIB_INSTALL ~s" site-package))))))
+ ,@(if (target-x86-32?)
+ `((add-after 'unpack 'skip-faulty-test
+ (lambda _
+ ;; This test fails on i686 when comparing floating point
+ ;; values, probably due to excess precision. However,
+ ;; '-fexcess-precision' is not implemented for C++ in
+ ;; GCC 10 so just skip it.
+ (substitute* "tests/CMakeLists.txt"
+ (("bezier-test") "")))))
+ '()))))
(native-inputs `(("python" ,python-wrapper)
("googletest" ,googletest)
("pkg-config" ,pkg-config)))