summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-17 10:32:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-17 10:34:32 +0300
commit2d4514e92c346820219e5c03e9e455e9f0f74e35 (patch)
tree01c3bb91e13dff552e21852092393852f4989347 /gnu/packages/graphics.scm
parent3bb3d7f371d6552db57d0401b375c415f21c9591 (diff)
downloadguix-patches-2d4514e92c346820219e5c03e9e455e9f0f74e35.tar
guix-patches-2d4514e92c346820219e5c03e9e455e9f0f74e35.tar.gz
gnu: assimp: Update to 4.1.0.
* gnu/packages/graphics.scm (assimp): Update to 4.1.0. [source]: Don't use unstable tarball. [home-page]: Update home-page.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 243814c14d..ad5ff8ed1e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -161,19 +161,20 @@ application can be customized via its API for Python scripting.")
(define-public assimp
(package
(name "assimp")
- (version "3.3.1")
+ (version "4.1.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/assimp/assimp/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/assimp/assimp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1gy7zlgkf4nmyv8n674p3f30asis0gjz8icyy11i693n13ww71fk"))))
+ "1rhyqfhzifdj7yibyanph3rh13ykw3i98dnn8mz65j780472hw28"))))
(build-system cmake-build-system)
(inputs
`(("zlib" ,zlib)))
- (home-page "http://assimp.org/")
+ (home-page "http://www.assimp.org/")
(synopsis "Asset import library")
(description
"The Open Asset Import Library loads more than 40 3D file formats into