summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-07 23:13:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-08 05:29:30 +0200
commit24268ec4184860192d2ec9043501ab6dc8aee99e (patch)
tree3d0405d6e4c6350d80f18a0d8e4a5eb43646992d /gnu/packages/graphics.scm
parent9be266116ba274ecf6a66178c17e51414dde3eec (diff)
downloadguix-patches-24268ec4184860192d2ec9043501ab6dc8aee99e.tar
guix-patches-24268ec4184860192d2ec9043501ab6dc8aee99e.tar.gz
gnu: coin3D: Use a specific changeset.
* gnu/packages/graphics.scm (coin3D)[source]: Use HG-FETCH and… GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm86
1 files changed, 46 insertions, 40 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 88bb500450..caaf6c660b 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
@@ -79,6 +79,7 @@
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix hg-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils))
@@ -1106,47 +1107,52 @@ or by subtracting one shape from the other.")
(license license:gpl2))))
(define-public coin3D
- (package
- (name "coin3D")
- (version "4.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://bitbucket.org/Coin3D/coin/downloads/coin-"
- version "-src.zip"))
- (sha256
- (base32
- "1mqwlqzvc9ydfxi0bfskwlil16mbnkphfz36p0zl2mvw6h05aqh0"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file
- '("cfg/csubst.exe"
- "cfg/wrapmsvc.exe"))
- #t))))
- (build-system cmake-build-system)
- (native-inputs
- `(("doxygen" ,doxygen)
- ("graphviz" ,graphviz)))
- (inputs
- `(("boost" ,boost)
- ("freeglut" ,freeglut)
- ("glew" ,glew)))
- (arguments
- `(#:configure-flags
- (list
- "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
- (string-append "-DBOOST_ROOT="
- (assoc-ref %build-inputs "boost")))))
- (home-page "https://bitbucket.org/Coin3D/coin/wiki/Home")
- (synopsis
- "High-level 3D visualization library with Open Inventor 2.1 API")
- (description
- "Coin is a 3D graphics library with an Application Programming Interface
+ ;; The ‘4.0.0’ zip archive isn't stable, nor in fact a release. See:
+ ;; https://bitbucket.org/Coin3D/coin/issues/179/coin-400-srczip-has-been-modified
+ (let ((revision 1)
+ (changeset "ab8d0e47a4de3230a8137feb39c142d6ba45f97d"))
+ (package
+ (name "coin3D")
+ (version
+ (simple-format #f "3.1.3-~A-~A" revision (string-take changeset 7)))
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://bitbucket.org/Coin3D/coin")
+ (changeset changeset)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ff44jz6lg4rylljvy69n1hcjh9y6achbv9jpn1cv2sf8cxn3r2j"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file
+ '("cfg/csubst.exe"
+ "cfg/wrapmsvc.exe"))
+ #t))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("graphviz" ,graphviz)))
+ (inputs
+ `(("boost" ,boost)
+ ("freeglut" ,freeglut)
+ ("glew" ,glew)))
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
+ (string-append "-DBOOST_ROOT="
+ (assoc-ref %build-inputs "boost")))))
+ (home-page "https://bitbucket.org/Coin3D/coin/wiki/Home")
+ (synopsis
+ "High-level 3D visualization library with Open Inventor 2.1 API")
+ (description
+ "Coin is a 3D graphics library with an Application Programming Interface
based on the Open Inventor 2.1 API. For those who are not familiar with
Open Inventor, it is a scene-graph based retain-mode rendering and model
interaction library, written in C++, which has become the de facto
standard graphics library for 3D visualization and visual simulation
software in the scientific and engineering community.")
- (license license:bsd-3)))
+ (license license:bsd-3))))