summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-09 16:29:15 -0500
committerLeo Famulari <leo@famulari.name>2022-01-09 16:32:14 -0500
commit23da063ea3bb6a579f0fb87d2e5e00fed9962775 (patch)
tree2071c2fc6a1014ef9a435d4d9082ac739e8b495a /gnu/packages/graphics.scm
parent531d986e01441eb31345922b2b99b4aa2277b9e7 (diff)
downloadguix-patches-23da063ea3bb6a579f0fb87d2e5e00fed9962775.tar
guix-patches-23da063ea3bb6a579f0fb87d2e5e00fed9962775.tar.gz
gnu: Remove blender-2.79.
This package has not built successfully in a while. * gnu/packages/graphics.scm (blender-2.79): Remove variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm97
1 files changed, 0 insertions, 97 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index fe35aaad2d..fb3fa49a89 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -511,103 +511,6 @@ compositing and motion tracking, even video editing and game creation. The
application can be customized via its API for Python scripting.")
(license license:gpl2+)))
-(define-public blender-2.79
- (package
- (name "blender")
- (version "2.79b")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.blender.org/source/"
- "blender-" version ".tar.gz"))
- (sha256
- (base32
- "1g4kcdqmf67srzhi3hkdnr4z1ph4h9sza1pahz38mrj998q4r52c"))
- (patches (search-patches "blender-2.79-newer-ffmpeg.patch"
- "blender-2.79-oiio2.patch"
- ;; The following patches may be
- ;; needed when the default GCC is
- ;; updated:
- ;; "blender-2.79-gcc8.patch"
- ;; "blender-2.79-gcc9.patch"
- "blender-2.79-python-3.7-fix.patch"
- "blender-2.79-python-3.8-fix.patch"))))
- (build-system cmake-build-system)
- (arguments
- (let ((python-version (version-major+minor (package-version python))))
- `(;; Test files are very large and not included in the release tarball.
- #:tests? #f
- #:configure-flags
- (list "-DWITH_CODEC_FFMPEG=ON"
- "-DWITH_CODEC_SNDFILE=ON"
- "-DWITH_CYCLES=ON"
- "-DWITH_DOC_MANPAGE=ON"
- "-DWITH_FFTW3=ON"
- "-DWITH_GAMEENGINE=ON"
- "-DWITH_IMAGE_OPENJPEG=ON"
- "-DWITH_INPUT_NDOF=ON"
- "-DWITH_INSTALL_PORTABLE=OFF"
- "-DWITH_JACK=ON"
- "-DWITH_MOD_OCEANSIM=ON"
- "-DWITH_PLAYER=ON"
- "-DWITH_PYTHON_INSTALL=OFF"
- "-DWITH_PYTHON_INSTALL=OFF"
- "-DWITH_SYSTEM_OPENJPEG=ON"
- (string-append "-DPYTHON_LIBRARY=python" ,python-version)
- (string-append "-DPYTHON_LIBPATH=" (assoc-ref %build-inputs "python")
- "/lib")
- (string-append "-DPYTHON_INCLUDE_DIR=" (assoc-ref %build-inputs "python")
- "/include/python" ,python-version)
- (string-append "-DPYTHON_VERSION=" ,python-version))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-broken-import
- (lambda _
- (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
- (("import encode_bin") "from . import encode_bin"))
- #t))
- (add-after 'set-paths 'add-ilmbase-include-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; OpenEXR propagates ilmbase, but its include files do not appear
- ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
- ;; the CPATH to satisfy the dependency on "half.h".
- (setenv "CPATH"
- (string-append
- (search-input-directory inputs "include/OpenEXR")
- ":" (or (getenv "CPATH") "")))))))))
- (inputs
- `(("boost" ,boost)
- ("jemalloc" ,jemalloc)
- ("libx11" ,libx11)
- ("opencolorio" ,opencolorio)
- ("openimageio" ,openimageio)
- ("openexr" ,openexr-2)
- ("ilmbase" ,ilmbase)
- ("openjpeg" ,openjpeg)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("ffmpeg" ,ffmpeg)
- ("fftw" ,fftw)
- ("jack" ,jack-1)
- ("libsndfile" ,libsndfile)
- ("freetype" ,freetype)
- ("glew" ,glew)
- ("openal" ,openal)
- ("pugixml" ,pugixml)
- ("python" ,python)
- ("zlib" ,zlib)))
- (home-page "https://blender.org/")
- (synopsis "3D graphics creation suite")
- (description
- "Blender is a 3D graphics creation suite. It supports the entirety of
-the 3D pipeline—modeling, rigging, animation, simulation, rendering,
-compositing and motion tracking, even video editing and game creation. The
-application can be customized via its API for Python scripting.
-
-NOTE: This older version of Blender is the last release that does not require
-OpenGL 3. It is retained for use with older computers.")
- (license license:gpl2+)))
-
(define-public goxel
(package
(name "goxel")