summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorGabriel Arazas <foo.dogsquared@gmail.com>2020-09-12 17:33:32 +0800
committerLudovic Courtès <ludo@gnu.org>2020-09-15 14:40:20 +0200
commit1c21468c7a7d09fbe065d1ceebf5f542537c877c (patch)
treeb9f6b58904f18ec298cfbb93cb7cdc244c87f3ba /gnu/packages/graphics.scm
parentb911d6547444b5f8d17b224bafa5ee1b5aafaff5 (diff)
downloadguix-patches-1c21468c7a7d09fbe065d1ceebf5f542537c877c.tar
guix-patches-1c21468c7a7d09fbe065d1ceebf5f542537c877c.tar.gz
gnu: Add goxel.
* gnu/packages/graphics.scm (goxel): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index cf52984183..d0bf577139 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -614,6 +615,39 @@ NOTE: This older version of Blender is the last release that does not require
OpenGL 3. It is retained for use with older computers.")
(license license:gpl2+)))
+(define-public goxel
+ (package
+ (name "goxel")
+ (version "0.10.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/guillaumechereau/goxel")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wmxy5wfk1xrqgz0y0zcr4vkddylqc70cv4vzk117x6whjnldsm3"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases (delete 'configure))
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "release")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk3" ,gtk+)
+ ("glfw" ,glfw)
+ ("scons" ,scons)))
+ (home-page "https://goxel.xyz/")
+ (synopsis "Voxel editor")
+ (description
+ "Goxel is a voxel editor that features unlimited scene size, unlimited
+history buffer, 24-bit RGB colors, layers, procedural rendering, ray tracing,
+and export to various formats including the format used by Magicavoxel.")
+ (license license:gpl3+)))
+
(define-public assimp
(package
(name "assimp")